This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 5 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 10, 2019 at 5:11 pm #3579297

maurizioP

Hello,

we have a problem with Translation manager in a website.

When we save a translation, the page translated is perfect. But when we modify other parts of the page in the original language we see that in the translation manager some boxes already green and already translated and correctly visible in the frontend, are in the original language. So if we save the translation manager we subscribed (also in frontend) these pieces of text with the original language.

We see this problem in half of the website pages and in random boxes. For the realization we have used WordPress + Divi theme. All plugin are updated at the latest version.

Thanks in advance for your help

April 10, 2019 at 8:01 pm #3581093

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When changing something in the original language, it is expected that you would need to translate it again on the Translation Editor. But you say that in your case, the original language is overriding the translations. Is this correct?
You also wrote: " So if we save the translation manager we subscribed (also in frontend) these pieces of text with the original language."
I do not understand this part. I do not understand if the text in the original language also shows on the frontend even if you fix it on the Translation Editor.
Could you please explain to me what is happening?
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Also please fix the following and see if solves the issue that you have. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

April 11, 2019 at 2:37 pm #3589093

maurizioP

The problem is that the translation process is correct:
1. I create the page in the original language
2. I translate the page with Translation Manager taking care that all the box are checked with “translation is completed”
3. Save and Close
4. Check Front End OK, the translation is shown correctly

BUT sometimes when i enter in the Translation manager because for example i have to change something in the translation (so with or without changes in the original language) I SEE SOME TEXT BOX VALORED WITH THE ORIGINAL LANGUAGE INSTEAD OF THE TRANSLATION. If i Cancel (do not save) and i take a look at the front end, the page is still translate correctly even if in the back end it shows some text boxes in original language. So you understand that if i do not take care (checking all the boxes all the times) it may happen that when i save i overwrite the translated content with the original one.

I upload a screenshot of another website with the same issue. In the frontend both languages are ok but when i save the a new box in the original language (italian) and i open translation manager the side with english language is full of italian texts.

April 11, 2019 at 5:10 pm #3591055

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

In the past, we've had some similar issue, but currently, I do not see similar reports with the Divi theme.
Is it happening with particular Divi modules?
I can see that you are using some plugins that extend Divi.
- Divi Widget Builder
- Anything Slider - Divi
- Popups for Divi
Is it happening with strings from those plugins?
I can see that you are using a child theme for Divi, but I cannot see if Divi as the parent theme is updated to its latest version.
Is it updated to its latest version on your site?
If not then please update it and see if the issue persists.

Problems like could also happen if you mix translation methods. This means if after translating the page with WPML's Translation Editor, you also edited the translated page with the WordPress editor.
Is it possible that something like that happened?

Regards,
Itamar.

April 12, 2019 at 10:07 am #3597425

maurizioP

Hi Itamar,

this issue happen in the standard Divi modules, not related with the plugins that you have mentioned.

I can assure also that Divi parent theme is already updated at the latest version available and that I've used only translation manager to translate this website. Could be other things that cause this problem?

Thanks

April 14, 2019 at 4:00 pm #3608369

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

There is one thing that I've mentioned already and didn't get your response regarding it. I'm talking about the WP Memory Limit that is set to 64M on your site. I've mentioned this in my reply here https://wpml.org/forums/topic/parts-of-translated-content-subscribed-by-original-language/#post-3581093 It was my mistake that this value is set to 40M on your site because it is set to 64M. Nevertheless, this should be fixed as it might cause this issue. Please after that you adjust it check if the issue is happening on a new page because that I believe that it won't be fixed on pages where it already occurred. Those pages might need to be fixed manually by adding the translations again.

Please let me know if fixing the memory issue also fixes the Translation Editor problem.

Regards,
Itamar.

April 23, 2019 at 9:58 am #3661607

maurizioP

Hi, we raised the Memory Limit as suggested but today, again, it happened this:
- we edited one text block (adding a sentence) in a page in original language using back end editor mode and not visual builder
- we accessed the Translation manager to update the translation of this block that we edited in the original language (we should have just to add a sentence)
- in the corrispondent translated box we found the original language text instead of the old translated text (the original language has overwritten the translation) so we could not just add a sentence, we had to translate the whole text block again.

April 24, 2019 at 12:05 pm #3672453

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I was trying to replicate this issue with the Divi builder on my test site and I couldn't. When I make a change in the original language, the text block does not get overwritten in the Translation Editor. I would like to see this issue on your site. Could you please let me have access to your site tell me where to go to see the issue?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

The topic ‘[Closed] Parts of translated content subscribed by original language’ is closed to new replies.