Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 30, 2018 at 3:20 pm #2594787

ideaspace

I'm having issues with the new 'Passing session data between languages in domains' function. I have following below blogs

1) passing session data between languages in domains
https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/

Screenshot: hidden link

2) wpml cross domain language data
https://wpml.org/wpml-hook/wpml_cross_domain_language_data/

Screenshot: hidden link

I had following step as per blogs guides. but till facing issue. Session is not passing between languages English to French and French to English(domains)

Below is login credentials for session testing.
Username : ketan@108ideaspace.com
Password : ketan@123

July 31, 2018 at 8:56 am #2597410

ideaspace

please help me

July 31, 2018 at 6:49 pm #2599623

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

2.- If the issue persists after increasing the memory then I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

August 21, 2018 at 10:57 am #2662609

ideaspace

Hi,

We followed all your steps to check if issue get resolved in normal WP environment, the issue is still coming with WP default theme and only WPML plugin active.

We have also tried following solution but it also not worked.

define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

Can you please help us to fix this issue?

August 21, 2018 at 12:53 pm #2663117

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

August 23, 2018 at 12:45 am #2668355

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I applied some troubleshooting options in the site and flushed the WPEngine cache memory.

Could you tell me if the issue persists?
Best regards,
Carlos

August 23, 2018 at 12:07 pm #2670087

ideaspace

The issue is still persist. After language switch I have to login again.

August 23, 2018 at 6:32 pm #2671211

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just consulted our specialists and this is a known issue that happens on some hostings. Please ask your hosting providers to add this header (change the URLs):

X-Frame-Options "ALLOW-FROM <em><u>hidden link</u></em>"

Could you tell me if the issue persits?

Best regards,
Carlos

August 27, 2018 at 12:26 pm #2678052

ideaspace

we are talk with wpegine supporting team.

August 27, 2018 at 6:08 pm #2679636

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will be waiting for your message.

Best regards,
Carlos

August 28, 2018 at 12:26 pm #2682169

ideaspace

Hi Carlos,

Check my above private message, I updated WP Engine server credentials there. You can live chat with WP Engine technical support team and fix issue quickly. Let me know in case of any detail not worked.

August 28, 2018 at 2:45 pm #2683061

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just consulted our specialists and this issue comes from the server configuration, not from WPML, which means that it falls outside of our scope as a support service.

In this case I recommend you to ask the WPEngine to apply this configuration to the server: Content-Security-Policy: frame-ancestors my-trusty-site.com -> You need to change 'my-trusty-site.com' with the domain of the site.

In this link you will find more information about this configuration: hidden link

Thank you very much for your understanding!
Best regards,
Carlos

August 29, 2018 at 12:59 pm #2686452

ideaspace

Hi Ketan,

I want to thank you so much for your patience here. So this is the current nginx configuration that we have set up:

add_header X-Frame-Options "ALLOW-FROM hidden link";
add_header X-Frame-Options "ALLOW-FROM hidden link";
Also, when I curl out the login pages for both domains, it shows the x frame options:

So the configuration is already in place. I'm afraid that this is normal behavior when you login to the wordpress dashboard between 2 different top level domains. So there is a different wordpress logged in cookie hash per domain. Which means that logging into hidden link
and then navigating to the other root domain; hidden link it does not keep you logged in because the logged in cookie tokens reset due the cookie hash being changed.

August 29, 2018 at 8:21 pm #2687772

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

As you can see from your previous message, the cause of the issue is the configuration of the server, not WPML itself.

If the hosting service could apply the configuration suggested then the issue might be solved. Unfortunately this falls outside of our scope as a support service.

Please let me know if you need further assistance with WPML and I will be more than happy to help.
Best regards,
Carlos