This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Scott Newlands 1 week, 2 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
October 3, 2019 at 6:12 pm #4690639

Scott Newlands

I am trying to: set a password protect using the built-in WP password function for a page that is on the secondary language domain

Link to a page where the issue can be seen: N/A

I expected to see:

Instead, I got: On save the page just reverts back to public setting with no password. The primary page works fine.

October 4, 2019 at 8:20 am #4693907

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support!

As a first step, please try the following:
- Go to WPML -> Settings
- Scroll down to the Posts and pages synchronization section and deselect the options called Synchronize private flag and Synchronize password for password protected posts
- Click the Save button

This should allow you to set Page and Post privacy and password protection independently for translated items.

Please let us know if this solves your issue, otherwise I will be happy to assist you further.

October 4, 2019 at 2:28 pm #4696513

Scott Newlands

That worked beautifully, thank you! Can you please remove the URL from the post? I don't want it to show publicly.

October 4, 2019 at 2:28 pm #4696515

Scott Newlands

Thank you!