This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by nikolajW 2 weeks, 2 days ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 27, 2019 at 1:48 am #4650751

nikolajW

Hello,

see video for demonstration.
hidden link

I created a product in back-end manually.
If customer use the pay button in his back-end while already having a product in his cart/basket he will maintain seeing this product on checkout.

Regards

September 27, 2019 at 2:26 am #4650989

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I would like to ask how you are adding those pay buttons?

Are you using some custom code, while WPML is disabled it's showing

<em><u>hidden link</u></em>

But while WPML is enabled it's showing

<em><u>hidden link</u></em>

So it looks like the button link is not working properly when WPML is enabled.

Look forward to your reply.

Thanks

September 27, 2019 at 2:26 am #4650991

nikolajW

Hey, the pay button appears after manual order creation automatically.
Create order manually and than visit the customers orders page.

September 27, 2019 at 2:45 am #4651123

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, I recently tried to check this on a fresh install and it's working without any issues, being so, can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

If the problem exists, leave the site in minimal install for now, so I can debug further.

Look forward to your reply.

Thanks

September 27, 2019 at 3:59 am #4651595

nikolajW

Hey,

in following ticket the supporter could reproduce the same issue in a clean sandbox.
"Raja Mohammed : I am able to reproduce the same on sandbox I need to check this with the second tier for a detailed investigation. I will convert the chat to forum ticket for better follow up"

https://wpml.org/forums/topic/tranlated-checkout-page-of-manual-created-order-is-broken/

He suggested to try out this:
https://wpml.org/forums/topic/tranlated-checkout-page-of-manual-created-order-is-broken/#post-4645485

Sadly it didn't work out for me.
See Video for demonstration.
hidden link

Regards

September 27, 2019 at 4:52 am #4651715

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

If the issue is already being worked on, I request you to follow up on the same ticket. It doesn't make sense to work on a single issue in multiple ticket.

Can you reply back there and let him know that the issue is not reproduced with the steps you mentioned.

I request you mark this ticket as resolved.

Thanks

September 27, 2019 at 5:46 am #4651751

nikolajW

Ok, I close this ticket and if this specific issue still persist, after fixing the other issue, I open a new ticket with the same title.

Thank you for your help. 🙂

September 27, 2019 at 5:47 am #4651753

nikolajW

Other issue must be resolved first in order to see, whether this issue still persist.