This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The user was not able to translate "Pay with paypal" description
Solution:

The string is a plugin option and should be translated through the admin strings screen or with a custom XML configuration.
Add the following code to WPML->Settings->Custom XML Configuration.

<wpml-config>
    <admin-texts>
        <key name="woocommerce_ppec_paypal_settings">
            <key name="description" /></key>
    </admin-texts>
</wpml-config>

The string will be available in WPML->String Translation under domain "admin_texts_woocommerce_ppec_paypal_settings". See the attached image.
Relevant Documentation:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/
https://wpml.org/documentation/support/language-configuration-files/
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

This topic contains 4 replies, has 2 voices.

Last updated by Davide 2 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
August 2, 2019 at 1:35 pm #4330465

Davide

Hello,

in fact using the plugin I realized (not just me) that it has several issues.

Even the declared compatibility (WPML Ready) is not up to date and like the documentation, the authors promised to update it 2 years ago.
Thanks for the support!

You can also see for the similar problem I have with the string
'Pay via PayPal; you can pay with your credit card if you don't have a PayPal account. ', it is the default for 'WooCommerce PayPal Checkout Gateway' plugin but it can also be customized by user.

Or do I have to open another ticket?

August 2, 2019 at 3:22 pm #4331081

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

The string is translated in WPML, see the attached image. Can you please try with a default theme like Storefront or Twentyseventeen? I suspect that the theme is probably interfering. If it is the case, we'll need to reproduce it on one of our clean installs then escalate it to our compatibility team.

If the issue is also present with a default theme, please deactivate all plugins except WooCommerce and WPML plugins and check again.

Best regards,
Jamal

August 9, 2019 at 8:08 am #4368499

Davide

Hello,

I've make some test in migrated website on cloudways:

1 - set default theme Twentyseventeen
2 - disabled all plugins except: WPML, WooCommerce, WC Multilingual and WC PayPal Checkout Gateway (this last plugin have the string that doesn't appear translated into Italian)
3 - I also tried to disable WC Multilingual but as you can see in attached screenshots the result does not change.

August 9, 2019 at 10:22 am #4369403

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Actually, the string came from an option rather than the PayPal gateway plugin or the WooCommerce plugin.
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

I was able to translate it on the migrated site by configuring the option to be translatable.
First, add the following code to WPML->Settings->Custom XML Configuration.

<wpml-config>
    <admin-texts>
        <key name="woocommerce_ppec_paypal_settings">
            <key name="description" /></key>
    </admin-texts>
</wpml-config>

https://wpml.org/documentation/support/language-configuration-files/
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

The string will be available in WPML->String Translation under domain "admin_texts_woocommerce_ppec_paypal_settings". See the attached image.

Please check the migrated site to see how that was resolved. Let me know if you want me to help implement it on your live site.

Best regards,
Jamal

August 9, 2019 at 10:35 am #4369533

Davide

My issue is resolved now. Thank you!