Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Stripe payment method not appearing for default currency in checkout
Solution:
Client downgraded Wordpress from 6.0.3 to 5.9.5
Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Yvette 1 year, 7 months ago.

Assisted by: Yvette.

Author Posts
October 25, 2022 at 12:17 am #12303537

hansN-10

Hello,

I have installed Woocommerce multilingual & multicurrency plugin on my webstore.

I have set 2 currencies: Swedish krona (SEK) and Euro. Swedish krona is the default currency.

I have only one payment method in checkout, and that is Stripe woocommerce gateway.

When I visit my Woocommerce store and place a (test) order in the default currency SEK, and then go to checkout, there is no payment method available.

A message says: "Sorry, it seems that there are no available payment methods for your state. Please contact us if you require assistance or wish to make alternate arrangements."

But if I then switch currency from SEK to Euro, Stripe payment method appears in checkout.

If I go to Woocommerce multilingual & multicurrency and delete the secondary currency (Euro), and then go back to my Woocommerce store, the default currency SEK suddenly starts working (!), meaning that the Stripe gateway turns up in checkout.

I also noticed that when setting the secondary currency (Euro) in the Woocommerce multilingual & multicurrency plugin, I am asked to enter Publishable and Secret keys from my Stripe gateway.

But for the default currency (SEK), there is no option to enter these Publishable and Secret keys.

Can you please help me get the multi-currency aspects of my Woocommerce to work, so that the Stripe gateway appear in checkout for both default and secondary currencies?

Thank you.

I have tried to un-install, and then download a new copy of Woocommerce multilingual & multicurrency plugin, but it did not help. (but I am not sure if the plugin´s data was deleted when I deleted the plugin, because the same settings appear after I re-install the plugin)

I have also tried de-activating all the plugins on my site, except for:
Woocommerce
Woocommerce multilingual & multicurrency
Woocommerce stripe gateway

but that did not help either.

I am using the Storefront theme.

ej keys för sek.PNG
keys för euro.PNG
2 valutor.PNG
sorry.PNG
October 25, 2022 at 9:15 am #12305749

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello

I will be helping you. Could I take a look on your site?

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Please also provide your STRIPE keys in the private area when you respond. Are they "test" mode?

Thanks

October 25, 2022 at 1:13 pm #12307731

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello

In order to save the test keys you have to save 2xs. First you have to save the test keys in the modal window "Edit Account Keys" and then when that is done, you have to save the settings on the configuration panel "Save changes"

Then the edits will persevere. I did this for you.

For the other issue of the payments method not being seen, it happens even when WPML plugin is deactivated. So, I think you should do the following for fastest results:
- Contact your STRIPE plugin support
- Keep WPML CMS and our plugins deactivated
- Make STRIPE work on the standard setup (without our plugins active)

Once this is working, then reactivate our plugins and see if you still have the issue. Write back if the payment method is appearing when the plugins are off but not appearing when our plugins are active.

Do you agree with this approach?

October 25, 2022 at 2:33 pm #12308473

hansN-10

Hello,

ok, sounds good, I will try that!

October 26, 2022 at 8:08 am #12312629

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Thanks! Looking forward to hearing what STRIPE support finds.

October 27, 2022 at 12:32 am #12318813

hansN-10

Hi Yvette,

after extensive testing, my conclusion is that the plugin Woocommerce multilingual &multicurrency (which is where the additional currencies are set up), is not compatible with WordPress 6.0.3

I have downgraded to 5.9.5 and everything seems to be working now.

Thanks for your help!

October 27, 2022 at 10:02 am #12323227

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Oh! Ok. I will let others know.

Thank you for sharing that update. I will let right people know this on our end.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.