This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Andreas W. 7 months ago.

Assigned support staff: Andreas W..

Author Posts
March 20, 2019 at 8:43 pm #3393329

toddM-4

I'm using ACF to populate a resources directory. the site is in English and translated to Chinese. However, in Chinese the PDF pulls in a number id instead of the PDF URL string. The PDF will be the same for all languages, I just want the URL string to copy over.

Ive read articles, installed ACF Multilingual, checked to make sure the custom post type is set to copy... and still nothing changes.

March 20, 2019 at 8:54 pm #3393459

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Did you try to translate the ID on String Translation? This should usually be able to solve the issue.
In case it does not I would like to have a look at the issue myself.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

March 21, 2019 at 3:35 am #3395213

toddM-4

I tried a workaround that I can use as a backup plan so you may see some different fields in there now. Basically, my backup plan is creating fields for both English and Chinese in ACF and pulling in those fields into the table. Since we only use the Resources custom post to populate the table and link out, we don't really need the posts themselves to be translatable.

It's still not the best way to do it though so I'd like to figure this out. Feel free to add a resource or edit the Test one T000000. You can see the results on /resources page (English and Chinese). FYI, this is a dev site.

March 21, 2019 at 4:39 pm #3412581

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please go to Resources and translate D870600 - Selected propaganda rules concerning public security.
Further, on Media Translation everything is looking fine for this item. Once the resource is translated everything should appear proper.

Let me know if this solved the issue.

Kind regards
Andreas

March 21, 2019 at 4:54 pm #3413203

toddM-4

Hi Andreas, I translated D870600 and you will now see the PDF file shows up as a number when you are viewing in Chinese. The ones that are not translated look fine and display fine on the Chinese version because I have all the Resources posts set to "Make 'Resources' appear as translated".

But as soon as I translate one of them, it no longer displays the image properly.

March 21, 2019 at 6:09 pm #3416265

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I was trying to solve the issue but sadly without success. Possibly one of the plugins in the chain is causing a incompatibility with WPML.

Could you please add the plugins used to create the resources and the resource list inclusive ACF Pro to the following test site. I would like to test the plugins for compatibility.

hidden link

It would be aleo helpful of you could quick set up a test resource.

Thank you in advance.

Kind regards
Andreas

March 21, 2019 at 7:46 pm #3420117

toddM-4

Andreas, I uploaded the plugins and created a similar setup and it was working for me on the sandbox site. I'm not sure if this is a plugin issue on my side or the order of things. I've read the images need to be translated before the post is translated but I've tried that on my side with no luck.

Any help would be appreciated.

March 21, 2019 at 10:05 pm #3425649

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

If you need some assistance with these tasks, let me know. Would it be possible to test this on your site right now?

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

March 22, 2019 at 4:56 pm #3442611

toddM-4

Andreas, Something is not playing well on our dev site as I now get an 500 error after deactivating plugins. My tech guy is looking into things and I will let you know when we figure things out.

March 22, 2019 at 9:45 pm #3444319

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The 500 error most likely refers to y PHP error caused by compatibility between plugins or the theme.
https://wpml.org/faq/500-error/

Please enable the wp-debug feature in your wp-config.php file and provide us the debug.log results.
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] PDF file URL not translating’ is closed to new replies.