This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by magnusH-11 11 months, 4 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 18, 2018 at 8:36 am

magnusH-11

Hi!
I've translated a webbsite and everything went well.
But a while ago I discovered that on one or two pages, when I click on the pen to open the page in translation mode, all the PDF files are gone (on both the Swedish and English side).
I've done all the updates but all is still gone. But they exist on the webbsite when you open it as a visitor/viewer. They also exist in the Divi Builder which I have used.
How do I solve this?

I don't seem to be able to upload any pictures right now. But if you go to my previous ticket you can see some pictures there.

Best regards
Maria

September 19, 2018 at 1:01 pm #2748830

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Maria, thanks for contacting WPML support. I'll be happy to help you with this.

Can you please tell me specifically which page you are seeing this on? If I understand correctly, the PDFs just don't show on the page edit screen, but they do show on the front end and in the Divi builder. Is this correct? How did you add the PDF originally?

Also, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

September 20, 2018 at 8:52 am #2751484

magnusH-11

Hi Lauren!
If you look at the page Downloads you for instance see "Companybroschure", "Personal data policy", "General terms of delivery", "General terms of purchase". There also should be links to the PDF-files om both the Swedish side and the English side on the "translationpage" but they have disappeared.
When I added them in the first place I uploaded the pdf-files to Media in WP and then I added the links in Divi so when you click on the image you'll be transfered to the pdf.s. And the PDF.s translated to English I added on the "translationpage" where you see the Swedish part on the left side and the English part on the right side. (Being a bit over specific here 🙂
But the strange thing is, as you may see, that there is a text-block above the other once that I mentioned above that is filled with links and all the links seem to be intact on booth the Swedish and the English sida. Very wierd. They however are not connected to any images. The PDF-links are just connected to the text itself if you understand what I meen.
I increased the memory to 128. So far doesn't seem to help…

I've uploaded two images where you can see how it looks without the links and then from another page where the links are still there.

Thank you for trying to help me!!

Best regards

Maria

September 20, 2018 at 9:10 am #2751576

magnusH-11

Ps. I can see now that no PDF-links are there anymore. So if you look at the first enclosed image, that information is not there anymore.

September 20, 2018 at 7:24 pm #2753134

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the additional information. I just looked at the download page and in both languages, I see the PDF image and link, and when I click the link, the PDF opens up. Please see attached screenshots. Am I doing something different than what you are doing?

September 21, 2018 at 9:51 am #2754715

magnusH-11

Well yes. You are on the page itself. But if you log in to WP, choose Pages and then click on the pen where the English translation is you se both the Swedish text etc. and the English text. It's here where the PDF.s don't excist. And this meens that I can't change any of the PDF.s and I can't put in new once. I can place them in the Divi builder but when I need to tranfer or upload a PDF to the English site I can't.

If you look at Screenshot 1 you see what I meen. On screenshot two you see the files missing.
On screenshot 3 you can see the page called Our assortment, how it looks now. And on screenshot 4 you see how it looked before.

September 21, 2018 at 12:34 pm #2755194

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for clarifying, sorry I misunderstood. If you install WPML Media Translation and then translate the media files, does this show the correct image in English? Once media translation is installed you will see a new menu item under WPML. Here you can upload translated versions of your media files.

Please let me know if this resolves the issue, and if not, I'll continue troubleshooting.

October 1, 2018 at 6:41 am #2777195

magnusH-11

Hi again!
I installed the Media Translation and I understand what you meen. But translating the PDF.s are not the problem. It's the files disappearing in the translation mode. Before I could klick on the pencil and on the left side you could find all the Swedish text and documents and to add a translated document to the English site you just put in the URL to the right side of the Swedish PDF-link. But now the links are gone. I've tried to switch to the English site and put in the translated file directley into the page builder but it won't be accepted. So to do it correctly I asume I have to use WPML translation. But I really need to solve why the links has disappeared on both the Swedish (left side) and the English (right side). Look at the screenshots again. It's very obvious how it looks when the links are there and when they're not. Thanks for trying to help!!

October 1, 2018 at 2:33 pm #2778513

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like the element has changed. Previously when the URL was showing in the translation editor, you were using an image element. Now, the element is a "blurb". So I added this to your WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute>url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Please make any small update to the original page and save the changes. Then edit the translation. Do you now see the correct fields?

October 5, 2018 at 8:44 am #2789902

magnusH-11

I'm sorry Lauren but no 🙁
They're still not there.
I tried to switch to the english site and add the english version of the Companybroshure but the program won't let me solve it like that. I have to use WPML to place the link to the document there. But the feelds to put in links are still gone booth on the swedish and the english side. I don't understand how it can change like this. I have'nt changed anything from images to blurbs. If you look at the screenshots again, nr 4. Those are completely gone.

October 5, 2018 at 3:23 pm #2791199

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

My apologies, I had a typo in the shortcode that I added to the custom xml configuration. I fixed the typo. I then updated the downloads page and now you can see the URL fields and the image fields in the Translation Editor.

Please let me know if you need any further assistance and I will be happy to help.

October 8, 2018 at 11:56 am #2795906

magnusH-11

Hi Lauren!
Thank you thank you thank you!!! Now everything looks just like it did before on the Download page. Is it possible to do the same for all the onther pages. I still don't see the links to documents and images there.

October 8, 2018 at 2:52 pm #2796513

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To see the links on the other pages, edit the page in the original language, make any small change, and click Update. Then, when you view the translation editor, you should see the links there. Let me know if not and I will be happy to take another look.

October 9, 2018 at 8:04 am #2798735

magnusH-11

I've made the small changes and updated the pages but I still don't see the links…
But the Download page works beautifully. Can you please look at the rest. For example, on the Home-page there are five "buttens" which holds information about the diffrent materials. Those links are gone in the translation and also the "buttens" or images. And it's the same on all the other pages.

October 9, 2018 at 3:08 pm #2800711

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This may be due to the new way that media files are translated. To test this, could you please go to WPML -> Media Translation and try translating the images for these buttons? Then let me know if the translated images display correctly in your secondary language.

Thanks!