This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 8, 2019 at 6:56 pm #4365483

THE OTTAWA HOSPITAL CIVIC CAMPUS

I am trying to: access the pdf file

Link to a page where the issue can be seen:

I expected to see:

Instead, I got: the error message

August 8, 2019 at 9:13 pm #4366079

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 12, 2019 at 12:32 pm #4380719

THE OTTAWA HOSPITAL CIVIC CAMPUS

Hi,

I have attached the debug information. The version 4.2.7.1 plugin is not allowing me to open any documents, I am getting the page is not working message. The Featured images size became very small. Could you please fix this ASAP.

Thanks.

Vanaja

August 12, 2019 at 1:15 pm #4381217

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

1.- However you didn't described the steps to reproduce the issue. Please describe step by step how to reproduce the issue in the site.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 12, 2019 at 8:32 pm #4383543

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,

1.- I couldn't log in the site using the credentials provided. Please double check the wp-admin credentials and edit your previous private message if necessary.

2.- You haven't describe the steps to reproduce the issue. Without this information I can't start solving the issue. Please describe step by step how to reproduce the issue.

Regards,
Carlos

August 13, 2019 at 1:11 pm #4388327

THE OTTAWA HOSPITAL CIVIC CAMPUS

Okay, I updated the admin login information in my private message.

Here are the steps to reproduce the issue.

1. I updated the WPML Multilingual CMS plugin version to 4.2.7.1
2. When I checked the website for quality assurance, I figured out that all links to the PDF documents were not working. It showed the "Page not working" error.
3. One of our clients figured out another issue that the featured image size for all our posts became very smaller in size. The actual size of the image was 740X330 pixel.

I have attached the screenshots in my previous messages.

Hope this helps to resolve the issue.

Thanks.
Vanaja

August 13, 2019 at 2:15 pm #4388779

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,

This time I was able to log in the site correctly, however your description of the issue doesn't include step-by-step how to reproduce it. I found this link that looks similar but it doesn't contain any PDF: hidden link and I couldn't found any page or post that is titled 'quality assurance'.

Please attach screenshots that show step-by-step how to see the error. Or create a screencast where you reproduce the issue and share a download link of the video.

Regards,
Carlos

August 13, 2019 at 4:35 pm #4389503

THE OTTAWA HOSPITAL CIVIC CAMPUS

Hi,

First issue: PDFs broken links

1. Go to the Dashboard. If you mouseover the "The Ottawa Hospital" on the top-left corner, you can see the option, "Dashboard, Themes, Widgets, Menu". Click on Dashboard.
2. You will see the list of plugins and tools etc. on the left-hand side.
3. Click on Documents (dashboard-documents.jpg screenshot attached).
4. You will see the list of documents on our website (documents-accessibility.jpg screenshot attached).
5. Click the view button on any one of the documents listed. For e.g., if you mouse over on Accessibility Policy, you can see 4 options, "Edit|Quick Edit|Trash|View."
6. Click the View option. You will get the "This page isn't working" message on your browser. For your information, I am using Chrome. (error.jpg screenshot attached).
7. If you click any document to view you will get the same error message.
8. Another example, on this page hidden link, if you click the Abstract button (fourth blue button), which is linked to the PDF document. You will get the same error message. (page document.jpg screenshot attached).

Second Issue: Featured image size

1. Go to the Dashboard, click on Posts. (dashboard-posts.jpg screenshot attached)
2. You will get the list of posts on our website.
3. Click the view button for the 5th post "You're in my care: Smudge procedure gives comfort to Indigenous patients and families" (post-view.jpg screenshot attached).
4. It will take you to the page hidden link.
5. The Featured image on this page should be a banner image size (740X330 pixel). It had shrunk to the size 330X134. (featured image.jpg screenshot attached).

So, I have reported 2 issues 1. broken pdf link 2. the featured image.

Hope this time I have given everything you wanted to know to debug the issue.

Thanks.
Vanaja

August 14, 2019 at 9:54 am #4393871

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,
Thank you very much for your feedback.

1.- This time I was able to reproduce the issue related to the documents. However this issue is not related to WPML. You can double check it by deactivating WPML Multilingual CMS -our core plugin- and visiting the documents. You will see that the issue persists. This means that WPML is not causing this problem.

I recommend you to reach the plugin's authors and let them know about this issue, they should be able to help you find a solution.

2.- Regarding the second issue related to the featured image, I can't see the difference in size between languages in the page 'You’re in my care: Smudge procedure gives comfort to Indigenous patients and families'.

You can see in both translations that the size of the featured image is the same:
- hidden link -> This is the English version
- hidden link -> This is the French version

Attached you will find the sreenshots for both pages.

Regards,
Carlos

August 14, 2019 at 1:21 pm #4395221

THE OTTAWA HOSPITAL CIVIC CAMPUS

Hi,

I don't understand what happened in the test environment. Maybe some other issues going on. I have given you access to the live site. Use the same credentials. Please do the same reproduce steps here to check the documents.

In the live site,

1. I disabled the WPML core plugin and checked the documents, it is working perfectly. Please see the attached screenshots (WPML-deactivated.jpg, after WPML deactivated.jpd, PDF-after-deactivation.jpd).

2. It is working perfectly after I deactivated the WPML core plugin.

Regarding the image, the problem is in both English and French side (actually all issues). The plugin is affecting both English and French sites, just not only the English.

In our Staging site, hidden link I didn't upgrade the WPML plugin. Please see the attached screenshot older version-WPML.jpg. Here I don't have any problem in PDF or featured image (screenshot YIMC-banner.jpg).

This is the original size of the look of the page and image.

We are also facing other issues with contact form 7 and reCaptcha after I upgraded to the latest version of WPML Multilingual CMS plugin.

Since we are the hospital, we are getting lots of complaints regarding the pdfs and the contact forms. Please consider this as your priority and fix the issue.

Thanks.

Vanaja

August 15, 2019 at 5:56 pm #4402815

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,

1.- Regarding the original issue related to the Documents CPT: I was able to reproduce the issue and I suspect that the cause of this issue is related to the way this functionality is implemented. You can observe that the documents add an extra slash (/) in the URL, that's why they return errors when visited.

Could you tell me if you are using a plugin to create this documents? Or this functionality comes with the theme?

2.- I kindly ask you to open a new ticket for the featured image and another one for the Contact Form 7 and ReCaptcha. Please describe the steps to reproduce this issues and provide as much information as possible. This way we will be following the forum's rule of having one ticket per issue. It will also help future clients to find answers to similar issues.

Thank you very much for your understanding!
Best regards,
Carlos

August 15, 2019 at 6:57 pm #4403067

THE OTTAWA HOSPITAL CIVIC CAMPUS

I think we are using WP Document Revisions plugin.

There is no 'double slash' in the live site URL. (screenshot attached)

hidden link. I don't know why the test site is giving that 'double slash' in the URL. It is the copy of the live site.

I will open a separate ticket for the featured image, Contactform 7 and ReCaptcha.

Thanks.

Vanaja

August 15, 2019 at 9:12 pm #4403487

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,

The double slash is removed by WordPress or by the browser (not sure) while loading the document URL. You can double check this by editing a document and checking the URL.

As mentioned in one of my previous messages I recommend you to contact the plugin's authors and explain them this issue. As the plugin adds the slash in the URL they should be able to find a final solution.

This plugin doesn't appear in our Multilingual-Ready Plugins list, you can double check here: https://wpml.org/documentation/plugins-compatibility/
It means that this plugins hasn't been validated by our compatibility team yet, so I kindly ask you to invite them to join our Go Global Program in the following link: https://wpml.org/documentation/theme-compatibility/go-global-program/ In this program the authors of the plugin can get in touch directly to our compatibility specialists and solve this problem.

Regards,
Carlos

August 16, 2019 at 12:10 pm #4406191

THE OTTAWA HOSPITAL CIVIC CAMPUS

Hi,

Could you please give me the older version (3.9.4) of the plugin to replace the 4.2.7.1 version? Also, provide me with steps to replace. I would like to test the older version in my test site.

I would appreciate if you could do that for me.

Thanks.

Vanaja

August 16, 2019 at 12:43 pm #4406325

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vanaja,

Sure, you can download the previous versions of the plugin in https://wpml.org/account/downloads/ -> Click on the information icon and there you will find all the previous versions of WPML.

Regards,
Carlos