This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 4 voices.

Last updated by michalK-30 3 years, 9 months ago.

Assigned support staff: Mohammed.

Author Posts
January 13, 2016 at 10:46 am #786719

Sergio

Hello, I received 2 comments in the last few days, but they are not showing up. I received the notifications via email and I see there are 2 comments pending in wp-admin.

However they are not showing. Can you please help to resolve this issue?

January 13, 2016 at 1:12 pm #786874

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hello Sergio,

Thank you for contacting WPML support.

Could you please do this test.
- Please test the issue in the minimal environment,
To do that, disable all non WPML plugins and activate one of the default themes(e.g twenty fifteen) .

please let me know this test result.

Thanks.

January 13, 2016 at 1:21 pm #786879

Sergio

I did what you said. No changes.
Only when I disable "WPML Multilingual CMS" the comments will show up.

Problem 2:
Now that I changed to Twentyfifteen and went back to my theme, I lost the sidebar widgets. How to get them back?

January 13, 2016 at 3:34 pm #787069

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Sergio,

Please read this article that illustrates how to add widgets : hidden link

Please let me test the issue in a fresh WordPress installation and I will get back to you very soon.

Thanks.

January 13, 2016 at 3:39 pm #787073

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Sergio,

Please try to change the language from the admin bar and check if the pending comments appear.

If this didn't work, I will need to request temporary access (wp-admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible
- in order to be of better help. You will find the needed fields for this below the comment
area when you log in to leave your next reply.

The information you will enter is private which means only you and I can
see and have access to it.

// NOTE : Please make a complete backup of your website, It is good to have a backup.

Thanks.

January 13, 2016 at 3:48 pm #787078

Sergio

Yes, they only appear with English language. But the comments were added in the Polish posts. How's that possoble?

Sidebar
I know how to add widgets. But I don't remember all the widges that were there and their codes for text widgets. I thought that if you tell me to switch the theme, and then I go back to my theme, the widgets will go back there. But they disappear.

Why you didn't say that the widgets will disappear if I switch the theme?

January 13, 2016 at 5:19 pm #787192

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

I'm very sorry for this inconvenience . I's my fault because I focused on the comments issue and forgot to notify you to take a backup.

Could you please take a look at this discussion : https://wordpress.org/support/topic/switching-themes-turns-off-all-widgets?replies=4

About the comments issue, I have a website with two languages (EN,FR).
I've created a post in English and translated it to French and commented on both of the posts and found that everything went well.

I need to check the issue in your admin dashboard.
Please provide me with the access credentials in the next private reply.

Please backup your website or at least take a database backup so that we can make sure that your data is safe.

Thanks.

January 14, 2016 at 8:18 am #787555

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Sergio,

Thank you for the information.

I've commented on this article : hidden link
in both of the languages (English, Polish) . everything went well.

Please check the English pending comments page:
hidden link

Please check the Polish pending comments page:
hidden link

Thanks.

January 14, 2016 at 12:23 pm #787871

Sergio

Thanks, it seems it's working fine now.

February 22, 2018 at 8:31 am #1525811

michalK-30

Hello, the same situation as above in my case. Comments do not show in a comment section. I can approve or remove it just by editing example post, scrolling at the bottom and approving/removing comments from there. Comment section says there are pending comments, but I just can't see them there. What did you do to solve that?

July 20, 2019 at 1:47 pm #4249991

patrickL-55

same problem here, what did you do to solve it???

July 20, 2019 at 7:37 pm #4250457

michalK-30

Just click "All languages" here - hidden link