Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Mateus Getulio 8 months, 3 weeks ago.

Assigned support staff: Mateus Getulio.

Author Posts
September 26, 2021 at 8:29 am #9661173

zolM

Performance Issue

September 27, 2021 at 5:42 pm #9670625

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Welcome to the WPML support forum. I'll be glad to help you!

As discussed on the chat, have you created a staging website and installed the Query Monitor plugin? Please let us know about your results.

Also, have you read our documentation on how to optimize your site? Please check it out:
https://wpml.org/2012/01/can-your-site-run-faster/
http://wpml.org/faq/how-to-optimize-mysql-queries
http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Another attempt that you can try is to go to WPML -> Languages -> Make themes work multilingual and disable the "Adjust IDs for multilingual functionality" option. With this enabled, load times are higher.

Give those solutions a try and let me know if they help you. If you're still facing performance issues, please share with us the login information of the staging website created. I'm marking your next reply as private so that you can safely enter the requested data.

We're looking forward to your reply. Thank you!

Kind regards,
Mateus.

September 28, 2021 at 7:12 am #9673475

zolM

Hello, I am unable to create a staging site at the moment. However, I do have my website accessible in another server which can be accessed by updating the host files on the computer to the new IP. Would that be something you guys can consider as a staging site? as that's the only way I test my site at the moment.

September 28, 2021 at 1:45 pm #9678247

zolM

Hi,

I created the standing website but I'm not available to add the credentials information. How can I add it ? Thanks

September 28, 2021 at 6:46 pm #9680823

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for creating the staging website.

I'm marking your next reply as private, then you'll be able to see the proper fields and enter the login information. Let us know, please. Thanks!

Regards,
Mateus.

September 29, 2021 at 4:39 pm #9688839

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for providing the credentials.

Based on my tests and diagnosis, this problem seems to be server-related. We've migrated the website to a copy version (hosted on my local server) and I could update several posts and pages - old and new ones - without problems.

In the original staging website, I've also managed to make the 'Update' work after increasing the maximum execution time and the memory limit. However, it still takes a considerable time to conclude the action. After debugging it a bit more, I found this error on the logs generated by debug mode:

PHP Fatal error:  Allowed memory size of 792723456 bytes exhausted (tried to allocate 20480 bytes)

This error means that the allocated memory limit in your server is not enough. This can be easily fixed by your hosting provider. Please get in touch with them, show the error message and ask to increase the memory limit as much as they can for your plan. Then, check if the posts update will work smoothly this time.

Let us know about your results, please. Thanks!

Best,
Mateus.

September 30, 2021 at 8:45 am #9693275

zolM

Hi thank you for your response. I have updated my PHP configurations to increase memory_limit to 2048M.

My hosting is a Cloud compute:
64 GB NVMe storage
1 CPU
2 GB RAM
2 TB bandwith

Restarted the server but the problem remains. I have double checked that the memory limit is at least 2GB and yes it is at 2048M so I am not sure why as soon as I update a blog post my CPU goes to 100% and RAM goes to at least 80-90%.

I've even disabled the "Adjust IDs for multilingual functionality" option.

What are my options please? I really need to fix this and the problem only goes away if I disable WPML.

September 30, 2021 at 2:59 pm #9696953

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

October 1, 2021 at 3:22 pm #9704391

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus

October 3, 2021 at 2:09 pm #9711497

zolM

Thank you, as previously stated my server is 2GB of RAM, do you think I should increase my RAM or should 2GB be enough.

Also, the memory limit in my server should be?

October 4, 2021 at 2:43 pm #9717111

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

The values for the memory limit and the RAM should be enough.

Our team is checking this and very soon I'll provide you with updates. Thank you very much for your patience.

Regards,
Mateus.

October 6, 2021 at 3:07 pm #9734101

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks again for your patience.

Upon further inspection, our team has discovered that the problem is in the table "icl_string_packages". The table is missing auto-increment and indexes, and all packages there (110 packages) are with ID 0. To fix it on the copy version of the website, we have followed these steps:

- Make sure to have a complete website and database backup before proceeding
- First, we ran the media wizard in WPML -> Settings -> Media Translation (by clicking on 'Start'). Please bear in mind that this process can be a bit long
- Then, in order to correct the database issues, we've accessed it (through phpmyadmin, but you can use any other similar tool)
- To adjust the IDs of all entries, we ran this query: https://pastebin.com/MSfV9rXm
- And to add the auto-increment, this other query:

ALTER TABLE `wpstg0_icl_string_packages`
CHANGE `ID` `ID` bigint unsigned NOT NULL AUTO_INCREMENT PRIMARY KEY FIRST;

After these actions, the update process reduces considerably. Could you please give it a try on your end and let us know about the results? Thanks!

Best,
Mateus.