Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Osama Mersal 1 year, 2 months ago.

Assigned support staff: Osama Mersal.

Author Posts
May 19, 2021 at 7:05 pm #8803171

alexR-47

Hello, based on this ticket https://wpml.org/forums/topic/how-to-translate-pagination-button-previous/ I will open a new ticket regarding performance issue.

May 20, 2021 at 8:52 am #8806381

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

WPML needs resources to run its functions, and it depends on how many languages you have and how big your site is. Kindly take into consideration that you have so many languages along with many installed plugins. That makes your site slower after installing WPML.

Kindly check the following guides. They might help you know what causes the issue.
1- https://wpml.org/tutorials/2019/10/analyze-performance-issues-with-query-monitor/
2- https://wpml.org/faq/how-to-debug-performance-problems/

Thanks,
Osama

May 22, 2021 at 9:32 pm #8825889

alexR-47

Hello,

Thanks for the feedback.

I have 25 languages in total and 34 plugins but I use all of them, I wish to remove some but I can't unfortunately.

Before installing WPML the site was lightning fast even with 30 plugins (excluding WPML) but after I activated WPML and added 25 languages(24 + English) I started to feel the difference and I've read on your website that your plugin should not impact performance but in my case it does and I think it's because of so many plugins. I have another website with 40 languages and 15 plugins and it's lightning fast but I use another theme with it.

Anyways,

I installed and checked Query Monitor plugin and very strange it shows WPML is the slowest query I will attach the screenshot. Is it possible to fix this or to improve the performance? WPML seems to have a big performance impact on this website.

wpml1.jpg
May 22, 2021 at 9:40 pm #8825913

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your feedback. Could you please check that the "Track where strings appear on the site" and the "Auto-register strings for translation" options are disabled on the WPML-> String Translation page?

Also, kindly check the query monitor on the front end if you have a cache plugin.

Thanks,
Osama

May 22, 2021 at 9:49 pm #8825917

alexR-47

Hello, both options are disabled.

Currently I don't have any cache plugin enabled. I used to use W3 Total Cache but I had some issues on the blog posts page of WordPress, the tags appeared multiple times, duplicated so I disabled it for the moment and I can't find a better one which can bust the cache on the main pages because I am using a geo location plugin to display the banners for example on the main page / . WP-Rocket, WP Fastest Cache can't, they will cache that dynamic geolocated banner content.

But I did optimize the database and removed unnecessary stuff with WP Optimize. For the moment I don't know what else I can do 🙂

(this website runs on a VPS 6GB RAM, 4 cores, SSD)

May 22, 2021 at 10:06 pm #8825921

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for checking. I have 3 more ideas. Kindly allow me to share with you.

1) Could you please check the GTmatrix report about your site? (hidden link)
That might help you reduce the loading time and increase the speed.

2) Kindly go to WPML-> Support-> Troubleshooting page, and click on the following buttons one by one.
1- Clear WPML cache
2- Remove ghost entries
3- Optimize String tables

3) Kindly try the minimal installation and activate your plugins one by one to check if any of them is causing this issue with WPML.

Minimal installation means that you deactivate all of your plugins except WPML plugins and switch to WordPress themes like Twenty-Twenty. After that, activate your plugins one by one, then activate your current theme to check the speed after each plugin activation.

This idea won't solve the issue, but it could help to know what causes it.

❌ Please, take a full backup of your site before trying points 2 and 3. ❌

I hope this reply helps you. If you need further info, please let me know.

Best regards,
Osama

The topic ‘[Closed] Performance Issue’ is closed to new replies.