This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 1 month, 1 week ago.

Assigned support staff: Lauren.

Author Posts
May 12, 2020 at 3:29 pm #6114521

rahiedB

The client is experiencing slow performance only in the secondary language.

May 12, 2020 at 6:18 pm #6115995

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration has been completed. Thanks!

May 17, 2020 at 6:54 pm #6152777

rahiedB

Hi Lauren,

I have installed the plugin, and it was working on till my laptop screens go to sleeping mode.
and now i can't restart it again, i tried many times. and it was verry frustating. But not working for a second time.

is it possible to send new login or is there some else solution?

Please let me know.

Kind regards,

Rahied Bakridi

May 18, 2020 at 4:15 pm #6159989

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, do you mean that the migration did not work for you? If that didn't work, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/ or the All In One Migration plugin. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note if using Duplicator: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

May 22, 2020 at 7:22 pm #6197851

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the files. I have your site set up locally and ran the following tests:

1. I deactivated all non WPML plugins and switched to Twenty Twenty theme. I ran the clean up steps in the WPML -> Support -> Troubleshooting -> Clean Up steps, as well as the option further down on this page to optimize string translation tables. After refreshing the English frontend of your site once or twice, the load time is consistantly at 1.5 seconds.

2. I then switched back to the Divi theme with only WPML plugins and after refreshing 2-3 times, the load time for the frontend English is around 3 seconds.

3. I then started activating plugins one at a time. I noticed a huge increase in time when I activated Image optimization service by Optimole. Can you please try disabling that on your live site and see if you find any difference in performance? You may need to refresh the screen a few times after disabling, and/or clear your cache.

May 29, 2020 at 12:56 am #6244469

rahiedB

Hi There,

I have already done that. before there was no optimize plugin only WP-rocket.
i have deleted it already.

what do to for the footer to change in correct language ?

May 29, 2020 at 7:49 pm #6252559

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

After deleting that plugin, are you still experiencing slow performance in the second language? This ticket was opened specifically for performance issues. Please open a new ticket if you are having trouble translating the footer.

If you are still experiencing performance issues with the optimize and caching plugins deactivated/deleted, please ask your hosting provider to check the server logs to see if there are any errors displaying there. Thanks!