Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by George Botsev 5 years, 2 months ago.

Assigned support staff: George Botsev.

Author Posts
November 4, 2016 at 8:22 am #1129882

Sander

I have been talking to Amir in this post:
https://wpml.org/2016/10/all-set-woocommerce-multilingual/?replytocom=1562179#respond

I experience a lot of performance issues with Sitepress Multilingual Cms and Wpml String Translation. Amir told me to open a ticket here so you can give me some support.

P3 Performance.png
November 4, 2016 at 8:43 am #1129905

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, I am George from third tier support and I will try to help you with the issue.

In my experience, the issue may be related to W3 Total Cache - if not configured properly or if it is set to cache method to "DISK" - this usually somewhat degrades the performance because of the disk slowness.

Maybe it would be a good idea to test how it loads without W3 Total Cache?

The plugin P3 performance profiler is to general in its description of the problem.

Could you perhaps test with the plugin Query Monitor and/or Debug objects?

Also, it would be very nice, if I could get a temporary access or a duplicator clone of your site so that I could try to debug the issue.
I am activating the private reply so that you could share temporary login credentials with me (if you wish).
If you allow me to access your site, in the end, I would like to create a site clone with Duplicator.
Please let me know if I have your permission to do that.

November 4, 2016 at 9:10 am #1129930

Sander

Hi George,
The reason why I implemented W3 Total Cache in the first place was because the site was so slow. 🙂 I have shared the login details to my site. I'm also working with my hosting provider this morning to migrate to a VPS (also as a result of the slow performing site), I'm exploring all options here. 🙂

November 4, 2016 at 9:41 am #1129962

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I am afraid that I cannot access your site.
There seems to be a problem and I was blocked by your security measures.
It seems that the site is too much cached and the only security question for the login that I've got is 16-2 - and this several times.
I think that there might be something very wrong with your caching setup - perhaps some of the plugins that you use (like the one for the math question for login) are not working properly with caching.
This might explain other performance issues too - if you are using very old or obsolete plugins.

Could you take a look please?

November 4, 2016 at 10:13 am #1130007

Sander

Hi George,
I disabled W3 cache. Can you please try again?

November 4, 2016 at 11:02 am #1130045

Sander

Were you able to test it?

November 4, 2016 at 1:40 pm #1130198

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I just tested.
Now the captcha works, but the credentials that you provided for me return that they are not correct.
Perhaps there is some mistake in them - you can edit your private post and correct them.

November 4, 2016 at 1:40 pm #1130199

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I just tested.
Now the captcha works, but the credentials that you provided for me return that they are not correct.
Perhaps there is some mistake in them - you can edit your private post and correct them.

November 4, 2016 at 1:41 pm #1130203

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Maybe it would be faster if you provide me with Duplicator clone link.
I am activating the private reply once more for that.

November 4, 2016 at 2:20 pm #1130256

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

My IP address is blocked.
Please upload for me somewhere a duplicator clone so that I can investigate the issue.

November 4, 2016 at 2:48 pm #1130288

Sander

Hi George,
I created a duplicator package. I put the weTransfer URL in the "URL to admin" area.
Can you confirm you were able to download it?

November 4, 2016 at 2:52 pm #1130290

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Thank you very much!
I confirm that I am able to get the file.
I will get back to you as soon as I get it and run some tests.

November 4, 2016 at 3:51 pm #1130332

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, it seems that the duplicator that you sent me has some files missing - mainly related to the theme in the /inc/ folder.
There were some other files missing too like in example the core plugin for WPML - but I replaced it with a working copy.
Running your site with a standard theme and debugging it for performance issues produces very fast loading speeds for me, and I am unable to find the performance problem.

Could you please upload separately perhaps the missing files?

Can you guide me to a page where the performance issue is most prominent?

November 4, 2016 at 4:39 pm #1130373

Sander

Is there a way we can communicate a bit faster? Via skype or another chat application?

November 4, 2016 at 9:08 pm #1130492

Sander

I think the best way for you to examine my site is to log in to the site itself. I disabled the Captcha and made sure you ip is nog blocked. Can you please try to login again?

The topic ‘[Closed] Performance issues with Sitepress Multilingual Cms and Wpml String Translation.’ is closed to new replies.