Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by lukeT 1 month, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
March 3, 2021 at 11:12 pm #8222623

lukeT

Hi there,

Our site has 2 languages - English UK (base language) and English US. All fields (including the permalink) are no longer saving when editing English US pages. You enter the information, click publish and it simply reverts to what it was previously.

Please can you help? I cans supply login info for the staging website.

Thanks,

Luke

March 4, 2021 at 9:01 am #8225437

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Sure, I marked your next reply as private so that you can safely add credentials.

And provide me some screenshots so that I can understand the issue better, also with URLs, as I am not very clear on what exactly isn't saving and where.

Regards,
Bruno Kos

March 4, 2021 at 9:32 am #8225685

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I checked one random page hidden link - and the problem with this one, along with most likely others, is that they are duplicates and you need to make them not duplicates.

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#how-to-convert-a-translation-into-a-duplicate

"To convert a duplicate to a translation, follow the same steps, but click the Translate independently button. This will stop the post from automatically syncing with the default language content."

For as long as they are duplicates, these can't be updated.

Regards,
Bruno Kos

duplicate.jpg
need to click this.jpg
March 4, 2021 at 9:40 am #8225795

lukeT

Thanks for your swift response Bruno. Interestingly this option is not available to me. The language controls are located at the bottom of the edit form rather than the side (see attached).

Thanks,

Luke

Screenshot 2021-03-04 at 09.39.01.png
March 4, 2021 at 10:24 am #8226163

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

On that one I already fixed it, but you can see it on this one e.g.
hidden link

Regards,
Bruno Kos

another one.jpg
March 4, 2021 at 10:32 am #8226277

lukeT

Hi Bruno,

Thanks, so this page has the issue I am talking about:

hidden link

I do not see an option at all to "Translate independently", either in the side bar or at the bottom of the page.

If I save edits on this page they disappear.

Thanks,

Luke

Screenshot 2021-03-04 at 10.29.38.png
March 4, 2021 at 11:44 am #8226915

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

As far as I see, these are all custom fields added through ACF, right?

Are you using ACF plugin for them? Is so, did you set their translation preferences like this?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-translation-preferences-acf-fields

This plugin is needed for this to work:
https://wpml.org/download/acfml/?section=changelog

Regards,
Bruno Kos

all are not translate now.jpg
March 4, 2021 at 12:07 pm #8227231

lukeT

Hi Bruno,

Thanks for your help.

The language fieldset at the bottom of the page which does not contain the "Translate independently" option (as I think it should) is WPML generated. It just lives at the bottom of the page rather than the side (not sure why).

Yes, I am using ACF, I have played with the settings you mention to no avail and it still doesn't change the fact that the permalink does not update when the page is saved (a standard WordPress field).

I think the real problem here is that I can't see the "Translate independently" button. Do you know why this wouldn't be appearing?

Thanks,

Luke

March 4, 2021 at 1:09 pm #8227721

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The "Translate independently" button would not appear if this was already done.

I also changed translation preferences for these fields, and can modify translation now:
hidden link

For slugs, did you try about setting up this option?

Regards,
Bruno Kos

slug translation.jpg
changed fields.jpg
these are texts to be translated.jpg
March 4, 2021 at 1:50 pm #8228155

lukeT

Hi Bruno,

Thanks for your patience. On the page:

hidden link

The data hasn't actually saved. It appears too but if you refresh the browser window any changes disappear. Can you replicate this?

I will have a look at the slug option you suggest but there is still something wrong here 🙁

Thanks,

Luke

March 5, 2021 at 8:51 am #8234877

lukeT

Hi Bruno,

Hope all good. Are you able to replicate the issue I am seeing now? And do you have any ideas as to what might be causing it?

Many thanks,

Luke

March 7, 2021 at 8:45 am #8244453

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have no idea to be honest, as I am not sure how was I able to save it all in the first place, as if Kinsta saved it in caching or something.

But I was able to save it now, while page itself seems to be managed elsewhere now, or?

I am unable to edit any of these blocks now and see "A duplicate of this post was made. Please note that any changes you make to this post will be replaced when the duplicated version is republished."", I see it comes from Yoast, not sure about this functionality though.

Are you trying some custom setup now through hidden link, or?

Regards,
Bruno Kos

sdf.jpg
March 7, 2021 at 10:14 am #8244713

lukeT

Hi Bruno,

I have tried many things with that existing page. However the problem persists on any page in the US language, for example:

hidden link

See video:

hidden link

Can I just check, are you saying that the problem does not exist for you? Or that it is inconsistent?

Thanks,

Luke

March 7, 2021 at 2:49 pm #8245541

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am really unsure about this, I suspect Kinsta caching but not sure about that either, as I have never came across something like it.

Can I ask you the following then? In order to debug this issue, can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

I could do this myself as well, but I don't have interface to install plugins, not enough privileges as it seems.

Regards,
Bruno Kos

privileges.jpg
March 8, 2021 at 7:26 am #8248231

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In my localhost it doesn't happen, so I suspect some Kinsta caching config. hidden link

That why this is escalated to our 2nd tier team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos