This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Lauren 8 months ago.

Assigned support staff: Lauren.

Author Posts
February 11, 2019 at 4:16 pm

koichiroS

This is very similar to this topic (but this has never been answered)
https://wpml.org/forums/topic/permalinks-on-our-multilingual-site/

I am trying to:
Linking back to the translated English page (hidden link)
from clicking Top Menu (hidden link)
hidden link

Link to a page where the issue can be seen:
hidden link

I expected to see (for example):
hidden link

Instead, I got:
hidden link

February 11, 2019 at 4:58 pm #3184547

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I don't fully understand the issue, but I can see that in the top menu you created custom links for the menu items. In this case you need to manually add the 'lang' parameter to the link in the translated menu to work properly.

Please let me know if this helps with the issue.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

February 12, 2019 at 7:55 am #3186979

koichiroS

Thanks, Carlos for your reply.

So here is another question relating to "creating custom links for the menu items.", please.

My main (menu) language is Japanese and there are seem to be lots of English menu on "Appearance>Menu" section and I can not find the English Menu, which I should add the lang parameter to..... will you be able to help?

Many thanks. Ko

February 12, 2019 at 2:25 pm #3189142

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your message.

I visited Appearance -> Menus but I found nothing in that section, no menu created (see attached image).

Please update all outdated plugins and themes to their latest version. Outdated functionalities can cause conflicts in the code.

Regards,
Carlos

February 12, 2019 at 3:19 pm #3189423

koichiroS

Hi Carlos,

I have updated PHP memory (128mb) as mentioned.

One more question as I am trying to upgrade WP and Plugin.

I am using FTP credential, which works on Fetch (FTPS) on the WordPress Admin but it shows error as attached. Do you know why? or any other ways to update Version..? Please help!

ERROR: There was an error connecting to the server, Please verify the settings are correct.

February 12, 2019 at 10:52 pm #3191203

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Please contact your hosting provider to solve this issue. They should be able to help you.

Regards,
Carlos

February 18, 2019 at 12:20 pm #3212103

koichiroS

Hi Carlos, So we have been upgrading WP/Plugins/WPML to the latest version.
We are almost done but we still have not been able to do this "wpml-string-translation"
Please let me know how to do this. Many thanks. Ko

P.S.....and now Menu (from Appearance) seems to be OFF.....oh dear!

February 19, 2019 at 3:45 pm #3217781

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Carlos is on vacation for a few days so I'm stepping in to help out. I hope that is okay.

The message about String Translation is saying that you need to install the latest version. Your site does not allow me up date it for you via the Plugins -> Add New -> Commercial tab, so you will need to do this manually via FTP. You can download the latest version from here: https://wpml.org/account/downloads/

As for your menu, as Carlos mentioned in his earlier response, there are no menus showing in Appearance -> Menus. I suggest creating a main menu in your default language and setting it as the primary menu. Then, you can go to WPML -> Menus Sync which will sync translated pages to an English version of your menu. You can then edit the menu labels and custom links by going to Appearance -> Menus. Use the admin language switcher at the top of your dashboard to switch to English and you can add the translated content.

Please let me know if you need any further assistance and I will be happy to help.