This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 6, 2019 at 11:22 am

robinP-11

I am trying to:
With the help of Woo Category Base Permalink Fixer ( hidden link ), I'm trying to achieve a certain permalink structure.

This structure, is to get this result:
hidden link <- Shop base
hidden link <- Category
hidden link <- Category
hidden link <- Product

In norwegian, this should ideally be as follows:
hidden link <- Shop base
hidden link <- Category *404*
hidden link <- Category *404*
hidden link <- Product

Link to a page where the issue can be seen:
hidden link <- Category *404*
hidden link <- Category *404*

I expected to see:
I expect to see the norwegian versions of the categories.

Instead, I got:
hidden link <- Category *404*
hidden link <- Category *404*

Pressing Save Permalinks, and going back and forth and changing it back and forth only switches the bug from EN to NO, and I get the same problem in the opposite direction.

Now, I realize that this is not your fortay to help me with an issue, that is semi-related to another plugin, but any tips or help in solving either the issue I'm having or resolving the issue with WPML but retaining the intended category structure would be amazing.

Any help is most appreciated.

May 6, 2019 at 11:48 am #3748009

robinP-11

My apoligies! These links:

hidden link <- Category *404*
hidden link <- Category *404*

Should have been as follows in the above list:
hidden link <- Category *404*
hidden link <- Category *404*

Just forgot to add the -no that got added when I duplicated the products, categories etc.etc.
Copypasted to quickly.

Problem the same. Those should not result in 404s. They excist and all, they are just.... difficult due to the reasoning above.

EDIT and SIDENOTE: hidden link also doesn't work, just to disconnect that thought process aswell - but that IS what it's trying to do - when it should be trying to do /produkter , but due to english slug being /products it seems to be trying to do that "globally" - which I've seen work from time to time, but then it's like WPML reverts it after a bit

May 6, 2019 at 11:55 am #3748037

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thanks for writing in! I’m happy to help out.

It looks like a compatibility issue with the plugin. To debug compatibility issue quickly, it will be best to test the issue on a fresh new Installation, being so I would need your little help to pinpoint the issue further.

I have created a fresh new WordPress Installed test site here, hidden link you can click on the link to login.

Could you please use the same settings there and see if you can replicate the issue? Please don't use personal information on the site as it's a test site, I recommend using some dummy data.

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 6, 2019 at 12:58 pm #3748611

robinP-11

SHOPBASE
EN - hidden link *WORKS*
NO -hidden link *WORKS*

CATEGORY
EN - hidden link *404*
EN - hidden link *404*

NO - hidden link *ERROR, NO 404 - But should be /produkter/ not /products/ *
NO - hidden link *ERROR, NO 404 - But should be /produkter/ not /products/ *

PRODUCTS
hidden link *WORKS AS INTENDED*
NO - hidden link *WORKS**ERROR, NO 404 - But should be /produkter/ not /products/ *

Also, this is the same problem, just the opposite direction more or less. Same issue.

May 6, 2019 at 1:50 pm #3749401

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can confirm the issue, It seems like the plugin only works on one language.

To ensure that this plugin is made compatible with WPML we need to contact the plugin author and work with him on resolving the issue.

Could you please provide a link to your plugin's download ( or purchase) page as well as contact information (email?) to the plugin's author so we can contact him?

You do not need to do anything other than providing the plugin's author name and email. We will contact the author.

I look forward to your reply.

Thanks

The topic ‘[Closed] Permalinks not working as expected, results in 404, in either EN or NO’ is closed to new replies.