This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
How to add a backslash or extra character in front of the language name in the language switcher drop down?

Solution:
This needs a simple custom css

To change the letters/name that you see in the menu:
1. Go to WPML > Languages > Site Languages > Edit Languages : http://take.ms/hHj55
2. Fill the translation column with the letters you want: http://take.ms/fAcQm and save
3. Go to WPML > Languages > Menu Language Switcher > Edit : http://take.ms/txR4h
4. Select "Native Language Name": http://take.ms/n2Cp8

To add "/" symbol in front of the language switcher sub menu:

Add this css code to your theme custom css section :

.sub-menu .wpml-ls-native::before {
    content: "/";
}

This topic contains 2 replies, has 2 voices.

Last updated by aleixF 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 7, 2018 at 4:41 pm #2794014

aleixF

Hello,

I am trying to change my Menu Languafe Switcher in this aspect: " /cat /es /en /fr ". I just want change the letters, the all desing i like, it's only writte diferent thing. However, i have been looking for a diferents tickets about this problem but when i tried to change it's following the same.

Link to a page where the issue can be seen: hidden link

I expected to see my Menu Langua Switcher like this picture that i got from another web.

Thanks,

Aleix.

October 8, 2018 at 6:45 am #2794834

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

To change the letters/name that you see in the menu:
1. Go to WPML > Languages > Site Languages > Edit Languages : hidden link
2. Fill the translation column with the letters you want: hidden link and save
3. Go to WPML > Languages > Menu Language Switcher > Edit : hidden link
4. Select "Native Language Name": hidden link

To add "/" symbol in front of the language switcher sub menu:

Add this css code to your theme custom css section (Avada > Theme Options > Custom CSS section.) :

.sub-menu .wpml-ls-native::before {
    content: "/";
}

if that does not help try to add the code to the very bottom of Appearance > editor > style.css

Let me know the results.

Regards,
Riffaz.

October 8, 2018 at 1:40 pm #2796171

aleixF

My issue is resolved now. Thank you!