This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm using PHP 5.4. I get a message Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 32 bytes).

PHP Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 32 bytes) in /wpml-string-translation/classes/filters/class-wpml-displayed-string-filter.php on line 189

Solution: Please follow these steps:

1. Increase PHP memory: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2. Upgrade your PHP to the version 5.6 or above

Relevant Documentation: - https://wordpress.org/about/requirements/ - https://wpml.org/home/minimum-requirements/ - https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

This topic contains 9 replies, has 2 voices.

Last updated by Muriel 3 years, 1 month ago.

Assigned support staff: Dat Hoang.

Author Posts
July 19, 2016 at 8:53 am #964983

Muriel

Debug log shows constant these error messages:

PHP Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 32 bytes) in /home/g/h/ghyczynl/www/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-displayed-string-filter.php on line 189

PHP Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 105 bytes) in /home/g/h/ghyczynl/www/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-displayed-string-filter.php on line 191

PHP Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

I already have various issues with the string translation, see my other opened case.

Please help?

July 19, 2016 at 10:14 am #965209

Dat Hoang

In this case, you need to increase your PHP memory for your site and WordPress.

We suggest 256MB at least.

Please follow these documents:
* https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/
* https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Does that help?

July 19, 2016 at 12:58 pm #965587

Muriel

It was already set to 256. Have set it to 512, will check if that will help.

July 19, 2016 at 5:37 pm #966360

Muriel

Set it now to 1024, same issue.

July 20, 2016 at 3:42 am #966826

Dat Hoang

Thanks for your info.

#1,
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

#2,
After reviewing your WPML debug info, I see you're using PHP 5.4.x.
Can you please upgrade it to PHP 5.6 or above?
Reference: https://wordpress.org/about/requirements/

July 20, 2016 at 6:45 am #966922

Muriel

If I disable all WPML plug-ins, of course the website runs normally and no errors are logged.

The hosting provider does not want to upgrade anytime soon. 🙁

July 20, 2016 at 10:18 am #967445

Dat Hoang

#1,
Please read my request again. Disabling WPML plugins makes no sense here.
I'm asking to disable all NON-related WPML plugins. Can you please try again and let me know the result?

#2,
If so, I suggest cloning your site to somewhere with the newer PHP version (5.6+)?
You can use Duplicator for this purpose http://wordpress.org/plugins/duplicator/ .

#3,
It seems I missed another question. Where does the issue happen?
What do you do, or where do you go, then these errors are logged?

July 25, 2016 at 4:47 pm #974385

Muriel

Hi There,

We have had quite a debate with our hosting company and they finally agreed to upgrade the memory. So far this seems to have solved the issue(s). So will keep this ticket open this week. If there are not issues. it can be closed on friday. 🙂

July 26, 2016 at 7:02 am #975140

Dat Hoang

Great news indeed! 🙂

Please let me know if you have any other issue.

No need to reply if you don't have any update. Our system will just close tickets if there is no response in 4 weeks.

August 2, 2016 at 3:05 pm #986618

Muriel

Problem is resolved