This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Sergio 3 years, 3 months ago.

Assigned support staff: Joanna.

Author Posts
January 27, 2017 at 4:36 pm #1192570


Hello, If I try to edit the contact page (it's a page, not a post), and I click "Update", the changes I make, are being applied, however a blank screen appears.

In the server I see the following errors:

2017/01/27 17:27:32 [error] 26562#0: *1112888 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught InvalidArgumentException: element_id and type do not match for element_id:2860 the database contains post_attachment while this function was called with post_page in /var/www/
Stack trace:
#0 /var/www/ WPML_Set_Language->set(2860, 'post_page', '14', 'pl', 'en', true)
#1 /var/www/ SitePress->set_element_language_details(2860, 'post_page', '14', 'pl', 'en')
#2 /var/www/ WPML_Post_Translation->maybe_set_elid('14', 'page', 'pl', 2860, 'en')
#3 /var/www/" while reading response header from upstream, client:, server: <em><u>hidden link</u></em>, request: "POST /wp-admin/post.php HTTP/1.1", upstream: "<em><u>hidden link</u></em>:", host: "", referrer: "<em><u>hidden link</u></em>"

Can you please help?
This erro started to happen today.

January 27, 2017 at 5:34 pm #1192621


Hello Sergio,

You mentioned that the error appeared today. Did you change anything today, made any updates or something else?

Could you please check if the error still appears with all non-WPML plugins deactivated and the default theme active, e.g. Twenty Seventeen?
If not, please activate your plugins one by one and check the page each time. If the error doesn't appear, activate your theme as well.

If the issue still occurs, please test your website with the beta version that you can find at

Please let me know about the results of your tests.

I also noticed that your WP Memory Limit is set to 40MB and the WPML's minimum requirement is to have it on 128MB. You can easily increase the memory allocated to PHP. You'll find more info about it at
In brief:
1. Log into your FTP.
2. Edit the wp-config.php file.
3. Add the following code:

define( 'WP_MEMORY_LIMIT', '128M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

4. Save the file.

This will not resolve your issue, but it may save you from a headache in the future when you will have possibly stumbled upon some unexpected issues.

January 27, 2017 at 8:10 pm #1192719


Hello, I did what you said.
Before doing the test I had 3 plugins updates. I did not update.
I turned off everything apart from WPML.

I made the test. Still the same problem.

Then I updated "Contact form 7 from 4.6 to 4.6.1.
Still the same problem.

I increased the memory as you said.
Still the same problem.

I reverted all the changes back to the original state. Theme, plugins back on, etc.

I also noticed that this problem happens to some of the pages. Not to all of them though. But I can't find any similarity or common point/thing of those pages, that could help narrow down the page.

Then I uploaded the BETA WPML plugins and overwrote the files.... now the problem seems to be fixed. Can we keep this case open another few days for testing?


January 30, 2017 at 12:54 pm #1193657


Hello Sergio,

I just want to let you know that we've just released WPML 3.6.3. Please update WPML again to the stable version.

Additionally, it's not a problem if you want to keep this ticket opened for several days. Mark the ticket as resolved or post another reply whenever you are ready.

January 30, 2017 at 12:58 pm #1193663