This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
reports about PHP warnings after ACFML 1.2 update

Solution:
1. Go to wp-content/plugins/acfml/classes folder through FTP

2. Edit the file called class-wpml-acf-attachments.php

3. On line number 13 change this:

if ( is_serialized($value) ) {

to this

if ( is_serialized($value) || is_array($value) ) {

4. Save the changes.

This topic contains 8 replies, has 2 voices.

Last updated by andreasF-28 5 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 23, 2019 at 1:15 pm #3664241

andreasF-28

Hello,
since the last Update of WPML I'M getting a PHP Warning on that page:
hidden link
I'm seeing the same Warning in Frontend And Backend on top of my ACF Content Builder Field Group.

Warning: Illegal offset type in isset or empty in /is/htdocs/wp12233279_JN1JC903KN/www/sales-pioneers.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247

Warning: Illegal offset type in isset or empty in /is/htdocs/wp12233279_JN1JC903KN/www/sales-pioneers.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 257

Warning: Illegal offset type in /is/htdocs/wp12233279_JN1JC903KN/www/sales-pioneers.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 258

Warning: Illegal offset type in isset or empty in /is/htdocs/wp12233279_JN1JC903KN/www/sales-pioneers.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 262

Any Idea?

Kind regards,

Jan

April 23, 2019 at 1:35 pm #3664365

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You are using WPML 4.2.5 but the latest version is 4.2.6

Please update all your WPML plugins and check the issue.
You can check the latest versions here : https://wpml.org/account/downloads/

Let me know how it goes.

Regards,
Riffaz.

April 24, 2019 at 7:44 am #3669871

andreasF-28

Hi,
I updated to the latest version, still getting the warnings,
regards,
Jan

April 24, 2019 at 10:37 am #3671621

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please go to WPML > Settings > troubleshooting : hidden link
Click on

  • set language information
  • fix post type assignment

if that does not fix the issue click all the buttons there except reset.

Let me know how it goes.

Regards,

April 26, 2019 at 10:24 am #3689737

andreasF-28

Hi,
I made all the steps you told me with no result...
Any further idea?

April 29, 2019 at 5:24 am #3700011

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

the next reply is private.
let me know your site login details to check this.

Regards,

April 29, 2019 at 12:10 pm #3703055

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to our second tier support.
Please be patient till we get back to you.

Regards,

April 29, 2019 at 12:27 pm #3703135

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi.

By now our developers have recognized the problem, and they will fix it in future versions of the plugin. Meanwhile, there is a workaround that you can use. Here is what you need to do.

1. Go to wp-content/plugins/acfml/classes folder through FTP

2. Edit the file called class-wpml-acf-attachments.php

3. On line number 13 change this:

if ( is_serialized($value) ) {

to this

if ( is_serialized($value) || is_array($value) ) {

4. Save the changes.

Now the warning shouldn't appear, and you should see the gallery.
Please let me know if it is working for you.

When we have the version with the fix released we would inform you here.

Thanks,
Riffaz.

May 6, 2019 at 2:52 pm #3750175

andreasF-28

Hi, thank you for the Support, the fix ist working.
kind regards