Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by ole-andreasV 2 years, 4 months ago.

Assigned support staff: Bobby.

Author Posts
June 26, 2017 at 5:30 pm #1305886

ole-andreasV

I have recently updated WordPress and all my plugins.

Now I get the following error:
Please activate WPML Multilingual CMS to have WPML String Translation working

How do I solve this problem?

June 26, 2017 at 6:36 pm #1305949

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting the WPML support!

For being of bettter help, can you please provide you WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Please verify that you are using WPML CMS version 3.7.1 and its currently activated.

Also, do clear your cache as this might be cache related

June 26, 2017 at 7:14 pm #1305980

ole-andreasV

Thank you for commenting,

Sorry, but WPML can`t be found in the admin menu.

June 26, 2017 at 7:32 pm #1305995

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Go to Plugins->WPML Multingual CMS and activate it, if its not listed there

download WPML Multilingual CMS , install and activate it.
->https://wpml.org/account/downloads/

June 27, 2017 at 5:47 pm #1306911

ole-andreasV

It says the folder is already there.

I can delete the plugin folder and reinstall it, but I have stored alot of information, such as translations and settings. I guess they will be removed if I reinstall?

June 27, 2017 at 6:26 pm #1306940

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

They wont be removed as these settings are saved within your database incase you do need to delete and re install the WPML CMS plugins

June 27, 2017 at 7:57 pm #1307009

ole-andreasV

Okay,

Now I get the following errors:

WPML Update is Incomplete

You are running updated sitepress-multilingual-cms, but the following component is not updated:

wpml-string-translation
wpml-translation-management
Your site will not work as it should in this configuration Please update all components which you are using. For WPML components you can receive updates from your WPML.org account or automatically, after you register WPML.

June 27, 2017 at 8:28 pm #1307028

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 5, 2017 at 7:37 pm #1312983

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

The error stands correct.

You are running updated sitepress-multilingual-cms, but the following component is not updated:

wpml-string-translation
wpml-translation-management

Your WPML CMS version is the 3.7.1 therefore our latest version of WPML but your String Translation and Translation management plugins are outdated.

String Translation is 2.5.1 current version is 2.5.4
Translation Management is 2.2.6 current version is 2.3.1

Underneath your plugins it also mentions that the plugins are outdated and need to be updated.

You can get the latest versions from here along with the changelogs
-> wpml.org/account/downloads/

OR you can go to Plugins->Add new->Commercial and from within there updated them all.

I have updated the plugins for you , and the notice is removed now 🙂

July 5, 2017 at 7:41 pm #1312988

ole-andreasV

Okay, thank you for solving the problem.

July 5, 2017 at 7:42 pm #1312992

ole-andreasV

Thanks,