This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Riffaz 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 20, 2019 at 3:59 am #3843569

sermsakH

Tell us what you are trying to do?
I need to translate to another language as i already setting on wpml.

Is there any documentation that you are following?
I am following wpml - Documentation, but i am unclear and understand not much.

Is there a similar example that we can see?
hidden link
hidden link

What is the link to your site?
hidden link

May 20, 2019 at 4:29 am #3843597

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Your question is not clear.
May I ask what have you tried?
What you could not do?
Did you follow all the steps explained here ? hidden link

Let me know.

Regards,
Riffaz.

May 20, 2019 at 1:11 pm #3847139

sermsakH

Hello support team,

Thank you for your help.

After i've follow all the steps explained in hidden link
(please see attached file) only 1 page and it's display unsucess as you can see in hidden link

Please help to suggest again.

Regards,

Sermsak H

May 20, 2019 at 1:20 pm #3847241

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

May I ask what do you mean by unsuccess?
What happens when you click on 'finish' here ? hidden link

only 1 page and it's display unsucess
- do you mean you could not translate only this one and other pages are fine?
- or do you mean something else?

Regards,

May 21, 2019 at 1:31 am #3850763

sermsakH

Hello support team,

Thank you for your mail.

What happens when you click on 'finish' here ? hidden link
(Please see attached file test2.jpg) and the fontend not translate (please see attached test3.jpg)

do you mean you could not translate only this one and other pages are fine?
- i am only test this one.

Regards,

Sermsak H

May 21, 2019 at 8:23 am #3853157

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let us know your site login details to check this.
The next reply is private.

Regards,

May 22, 2019 at 1:11 pm #3866007

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

1) your max input vars is 1000. It is not enough for all these string and for such a big site.
Try to increase it to 10000 and check the issue.

2) when I visit to your pages these are keep loading: hidden link
It means that your hosting configuration or some other settings are not enough.

3) when I try to create page and try to switch the pages it takes too long and freezes for a while. So I could not check this properly.

4) please disable all the plugins and try to translate and see.

5) Also let me know the pages urls where you have this issue.

6) when you create an new simple page and try to translate do you see the same issue?

Let me know.

Regards,

May 23, 2019 at 3:16 am #3870735

sermsakH

Hello support team,

I've already done as your suggest, i've build the sample page name hidden link and the issue has disappear. (please see attached file)

Please help to suggestion.

Regards,

May 23, 2019 at 6:55 am #3871655

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I've build the sample page name hidden link and the issue has disappear.
- you mean you do not have any issue in translating in the test page, right?

This is because the you were using builder for the pages in the past and Translation Editor hides the editor contents in favor of page builder strings.

Please go to WPML > packages and delete the package of the pages: hidden link
Then try to translate the pages and you will be able to translate them..

Please note that it will delete the builder translated strings permanently.
So do this only when moving from your builder to native editor permanently not for testing.

Hopefully, this will help you to fix the issue.

Let me know how it goes.

Regards,
Riffaz.

May 23, 2019 at 9:02 am #3872733

sermsakH

Hello,

You asking, you mean you do not have any issue in translating in the test page, right?
- No, my test page hidden link it has the right display as has the right Menu , right Widget etc. but i don't translate it now. (please see attached file)

Now, I've importing my user from 2 mlm to 19 mlm and i need the clear plugins on my site.

Then, Can i've the CLEAN uninstalled and i will install FRESH install WPML again ?

Regards,

May 23, 2019 at 12:11 pm #3874921

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, in that case, please disable WPML. Delete it.

Please follow the steps explained here : https://wpml.org/forums/topic/full-uninstall/#post-2453014
If you miss any of this some of the WPML related contents/links/taxanomies will be in your database and that will effect the new installation again.
So please make sure you are following all these steps carefully.

And, after that if you have any issue, please open a new ticket with all the details.

Regards,

The topic ‘[Closed] Please help to use wpml translate for my site too.’ is closed to new replies.