This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 8 voices.

Last updated by George Botsev 3 years, 2 months ago.

Assigned support staff: George Botsev.

Author Posts
January 12, 2017 at 8:58 am #1180315

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

This ticket is created as a shortcut for escalating issues that may happen with WordPress 4.7.1

WordPress 4.7.1 was just released and we are currently doing tests if there are issues.

You can see a list of the changes introduced in WordPress here: https://core.trac.wordpress.org/query?milestone=4.7.1

Please add issues here that happened only after updating from WordPress 4.7 to 4.7.1.

January 12, 2017 at 12:24 pm #1180616

bjornJ-3

Updated to wordpress 4.7.1 and other WPML plugins...
Language switcher can't find main index pages
Switching from default language Danish to English gives:
hidden link
Nothing Found
Sorry, no posts matched your criteria
Should be for English: hidden link
Switching language between other pages seems to be working

Also had difficulties saving changes to menu after rearranging (dragging)
had to delete and recreate pages before changes took effect

Debug info can be given on request

January 12, 2017 at 1:07 pm #1180684

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello.
You said that you also updated other WPML plugins.
In my opinion the issue here might not be related directly to WordPress 4.7.1, but perhaps to other previous issues.
From which version did you do the upgrade?
Can you check Settings > Reading - if you have any warnings there, and perhaps set the home page once more time there.
I think that you are displaying the posts page, and because you have no posts - that is why the results are blank there. Usually re-setting the home and blog page in Settings > Reading helps with resolving such issues.

January 12, 2017 at 1:22 pm #1180700

bjornJ-3

OK did that, but it does not resolve the issue ?

January 12, 2017 at 1:37 pm #1180721

bjornJ-3

Resolved - cleared the caché and it is working now...
Thank You!

January 12, 2017 at 1:46 pm #1180730

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Thank you for getting back to us.
I am happy that the problem has been resolved.

January 13, 2017 at 9:29 am #1181400

Miquel

Whole shop went offline and tossing a 500 error.

"PHP Fatal error: Call to undefined method WPML_WP_API::is_comments_post_page() in /var/www/lvnwrth/wp-content/plugins/woocommerce-multilingual/inc/wcml-switch-lang-request.php on line 136"

public function get_requested_lang() {
return $this->wp_api->is_comments_post_page() ? $this->get_cookie_lang() : $this->get_request_uri_lang();
}

I commented out this return and the site came back to life. This appears to have just happened with recent upgrades, but I can't say for certain which exactly.

January 13, 2017 at 10:09 am #1181445

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello @miquel
The error that you are reporting here does not look to be related to the changes in WordPress 4.7.1

Please make sure that you have all of the latest versions of WPML plugins and WooCommerce Multilingual and check if the issue persist.

January 13, 2017 at 5:38 pm #1181938

Miquel

I'm fully updated to all latest releases.

My theme is the generic Storefront theme from Woocommerce with a child theme on top of it. Tried deleting the child theme, issue still persisted. Only solution was commenting out that line.

This is a WPML issue. I'm not the only person who says it's broken if you look at the plugin page on wordpress.org

January 16, 2017 at 7:33 am #1182591

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

@miquel, WPML plugin does not have a page at wordpress.org - it is not available for download from there.
Only WooCommerce Multilingual - one of our plugins that bridge WooCommerce and WPML has an official page there.
You can try this fix instead:

public function get_requested_lang() {

      return $this->is_comments_post_page() ? $this->get_cookie_lang() : $this->get_request_uri_lang();
  }

  public function is_comments_post_page() {
      global $pagenow;

      return 'wp-comments-post.php' === $pagenow;
  }

to replace the function that is causing the issue.

January 16, 2017 at 12:11 pm #1182911

pavloL

Hi,

After update got Errot 500 Message for any page except HOME page (example rofimi.com/)
All rest pages started receiving error 500 with Apache error log: AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: hidden link

I have re-saved permalinks and pages with default language ENglish, started to works.. Except. Italian.. All pages with site.com/it/ stopped working showing named error.

After I switched in WPML settings to >>> Language name added as a parameter (hidden link - Italian)
from>>>Different languages in directories ((hidden link - English, hidden link - Italian)) - I always had it before without any issues.

Then exploring the error I found that My .Htaccess file has something with "/it" in it.

## Default .htaccess file

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /it/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /it/index.php [L]
</IfModule>

Default Htaccess has only "/".

So my question is:

1. Why did this happen?
2. If I remove IT and leave / as per dafault, would it fix the issue and I can switch back to Different lang in directories?

January 16, 2017 at 1:17 pm #1182981

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

@pavlol you could have a compatibility issue with some plugin or your theme.
In the past we had similar looking issue where the language code was appended to the .htaccess file - but in all instances it was related to plugins that modify the .htaccess file - either related to caching or to SEO.
However, as far as I am aware such issues are long time resolved now.
If you have a way to reproduce this, please open a new ticket so that we can investigate this further with you.

January 16, 2017 at 6:50 pm #1183309

stephanieL-2

Hi guy's, i have a big probleme since your last version of WPML.
My site first language is French and my second is English. Since your last update, the dashboard is only in english, it is impossible to have it in French anymore, where as the first language of wordpress is check as french !

thank you for your help 🙂

I can send you my debuging information by private mail if you want.

January 16, 2017 at 11:08 pm #1183404

gerganaG

Hi guy's, i too have a big problem since your last version of WPML.

My site first language is Bulgarian and my second is English.

No Bulgarian Page load
and
English page loads but when you navigate you get missing products and 404 errors

Site Respectfully:
hidden link

hidden link

Admin Area:

The dashboard is only in english, can only add products in english
then after can't translate them bulgarian

January 16, 2017 at 11:39 pm #1183405

gerganaG

Update - tried going thru deactivating plugins one by one :

As soon as I disabled
woocommerce-multilingual

site came back up, so what could this be?