Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by gloriaF-3 1 year, 3 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 23, 2019 at 2:42 pm #3664837

gloriaF-3

So I tried multiple ways to translate the content but seems that all the viable automated options break things in terms of visual builder elements on my WP theme.

What I want to know is how to simply create a duplicate copy of my homepage into a different language and add my translated text into the visual builder editor on my own.

When I click "+" for different language, it redirects me to traslate mode (editor mode) but what I want is just to create a page dedicated for each language (same as the original content) and edit it from there.

April 23, 2019 at 4:10 pm #3666013

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I don't know what visual builder you are using but most of the popular ones should be compatible with WPML.

You can find out more about this here:
https://wpml.org/documentation/translating-your-contents/page-builders/

If you would just like to duplicate a page into another language and maintain the exact same visual builder structure, you could use the "Duplication" functionality instead of the "Translate" one.

In this link, you will find more information about how you can do that in case you never tried that method:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Just install WPML Translation Management in case you don't have it already (you can download it from your WPML.org account - Downloads section), create a new test page in the original language, create some test content using the visual builder and then follow the steps in that document above.

That should help you avoid any kind of translation overwriting issues.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 24, 2019 at 1:16 pm #3673333

gloriaF-3

I will try to do that for my next page.
But with this, I also have another problem.

Whenever I try to use the section of language url on WPML settings.

Choose how to determine which language visitors see contents in
Different languages in directories ((hidden link - English, hidden link - Indonesian))
A different domain per language
Language name added as a parameter (hidden link - Indonesian)
Language URL format

I want to use a different domain per language or use different languages in directories, both options do not work and I have to fall back to using the third option of language name added as a a parameter. Problem with 1st option is that once I click this, the page translated into Indonesian breaks and shows different designs. 3rd option, whenever I try to validate on save, it says I cannot.

Could you tell me what is wrong?

April 24, 2019 at 1:46 pm #3673579

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

If the original issue is resolved may I kindly ask you to please mark this ticket as resolved and open a new ticket for the additional issue?

Please let me know if the "Duplication" functionality I recommended above worked fine for you - it should work fine with most content builders.

I will be waiting for your response.

Kind regards,
Mihai

April 25, 2019 at 1:52 pm #3683075

gloriaF-3

My issue is resolved now. Thank you!