Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Bigul 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
April 19, 2020 at 6:44 pm #5943641

marcelW-23

I have products with attributes. For this I use the plugin C4D Woo Variation Images.
So hidden link
You have a couple of options/attributes to choose from.
Look at Nähen and Pootkleur, (under all the colored images) both have 2 options, but the images are not showing.
Look at hidden link (this is the original website that's being translated to .de) Here you'll see those 4 images correctly.

How do I make these 4 show up on the .de site?
I add the images as described as:
hidden link POINT: 11

April 21, 2020 at 6:05 am #5955233

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

May we have to set the translation preferences to the custom fields of C4D Woo Variation Images plugins. Please try the following steps and check you are getting the expected result or not.

1) Please open the hidden link product to edit
2) Scroll down to *Multilingual Content Setup* widget on the bottom of the screen
3) Check for the variation image fields in the *Custom Fields* section
4) May it be systems fields too, if so please check after clicking *Show system fields* link
5) Choose *Copy* as translation preference for the C4D Woo Variation Images
6) Apply the changes
7) Update the Product and its translation. Please check the attached images and following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Please note, *C4D Woo Variation Images* plugin is not listed on the WPML compatibility list for the Plugins - https://wpml.org/documentation/plugins-compatibility . It does not mean that this plugin is not compatible with WPML, but our compatibility team has not tested it yet.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

April 21, 2020 at 6:28 am #5955301

marcelW-23

Hello,

I did what you asked. Everything of C4D I checked 'copy'.
Doesn't fix it...
I even remove the german translation from those images and attribute.
Doesn't fix it...

Can you help?

April 21, 2020 at 1:32 pm #5959879

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

April 21, 2020 at 1:37 pm #5959901

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please check my previous reply. I have enabled the private information option for your next reply. Please share the site credentials after a full site backup.

--
Thanks!

Bigul

April 21, 2020 at 4:46 pm #5961817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. Please check the attached image. Somehow the C4D Woo Variation Images are not copied to the translated product.

It may be a compatibility issue and needs further checking. So please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

2020-04-21_2211.png
April 21, 2020 at 4:49 pm #5961871

marcelW-23

Yes, go ahead

April 22, 2020 at 6:53 am #5965077

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a copy of the site now, will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

April 23, 2020 at 9:13 am #5974741

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am still working on this ticket. But one issue, the frontend of the site is not loading fine in my local copy. The result is the same after switching to the 2020 theme, reinstalling WordPress, and deactivating all the plugins. Please check the attached images for more details.

Therefore I have tried to reproduce the issue in a fresh installation on our Sandbox server(Cloudways). Because as part of our escalation process we have to make sure the issue is existing in a fresh installation or minimal setup. But I am not able to reproduce the issue on the sandbox site. Only WooCommerce, C4D Woo Variation Images, and WPML plugins are active on the sandbox site and the theme is Storefront. Please check the following URLs for more details.

Log in URL - hidden link

Product 1 - hidden link

Product 2 - hidden link

So I have a request. Please visit the sandbox site and check you can reproduce the issue or not. It will help us a lot in debugging and we can easily escalate to our developers for fixing.

--
Thanks!

Bigul

April 23, 2020 at 9:24 am #5974855

marcelW-23

Hello,

Thanks for still working on this!
The website is indeed not showing right.
You removed plugins that are necessary for the theme and c4d Woo Variation Images.

Please install:
C4D Plugin Manager
Electro Extensions
Redux Framework

April 23, 2020 at 9:41 am #5975023

marcelW-23

Hello,

I reproduced the problem for you and I activated the
C4D Plugin Manager for you by the way.

I did the following:
On the product page in admin go to: attributes and add another attribute and also check the Used for variations box.
Add the images for these attributes in the Swatch Images section (rights side of the page)
and save

hidden link
hidden link

As you can see, the images are not on the /de/ site

April 23, 2020 at 9:42 am #5975025

marcelW-23

It's the second and third attributes that are not showing images

April 23, 2020 at 4:50 pm #5979705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and for reproducing the issue on the sandbox site. I have also noticed another conflict. When the variations are set from both attributes the variation swatch images are showing the featured image in translation - hidden link

I have escalated the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

April 23, 2020 at 5:34 pm #5980209

marcelW-23

I have changed your new-product-3. Just like i do on the LIVE site.
For the first attribute: Color, I do NOT set an image in the Swatch Images (right side column)
I set this image in the attribute itself, see attachment.
Images for other attributes like: stiksel, I do set those images in the Swatch Images (right side column)
I now see at: hidden link, at the attribute: stiksel, the same grey chair image as the first attribute.

attribute.png
April 24, 2020 at 9:16 am #5984541

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have shared the details with our compatibility team and they are currently working on this issue. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul