This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Oscar Miras 5 months ago.

Assigned support staff: Oscar Miras.

Author Posts
May 20, 2019 at 12:44 pm #3846869

muhammad-amirS-2

I am trying to: Translate the name of month in the Calendar

Link to a page where the issue can be seen: hidden link

I expected to see: The german version of the month

Instead, I got: English version

May 20, 2019 at 2:35 pm #3848019

Oscar Miras

Hi,

Welcome to the WPML support team.

Thank you for the provided debug information. I have checked your WordPress configuration parameters and the WordPress memory is a little bit low. Some problems such as not being able to translate some site components may happen when minimum requirements for WPML are not met: https://wpml.org/home/minimum-requirements/

Could you increase the WordPress memory in your wp-config.php file? The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

Change or modify the following lines:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Make sure you modify them before the line:

/* That's all, stop editing! Happy blogging. */

You can check if your values have been properly updated in WPML > Support.

Try to translate again the text in the Calendar to check if this solves the issue. Please, take into account that we have detailed information about how to translate sites built with Elementor https://wpml.org/documentation/plugins-compatibility/elementor/

If the issue persists, do not hesitate to contact me again. I'll be happy to help.

Kind regards,
Oscar.

May 22, 2019 at 10:25 am #3864247

muhammad-amirS-2

Hi Oscar,
Thanks I have increase the limit to 256MB. Translation still doesnot function.
Regards
Amir

May 22, 2019 at 11:38 am #3864811

Oscar Miras

Hi,

I have discussed this issue with my colleagues.
It seems that is already being managed by Itamar.
He told me that he's working on it and will come back to you when he gets some results.

Because he has a deeper knowledge of the issue, it is more convenient if you keep working on it at this thread: https://wpml.org/forums/topic/string-translation-79/

Thank you. Do not hesitate to contact the support team in case you need further assistance.

Kind regards,
Oscar.

May 22, 2019 at 1:11 pm #3866001

muhammad-amirS-2

Hi Oscar,
Thanks. Please close this ticket as Iiamar is working on the other Tickets with same issue.
Regards
Amir

May 22, 2019 at 1:30 pm #3866177

Oscar Miras

Hi Amir,

Ok, thank you for your feedback!

Best wishes,
Oscar.