This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by natalieR-4 4 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 22, 2019 at 8:19 pm

natalieR-4

I am trying to:

activate WPML Multiligual CMS and I'm getting the following notification:

Plugin could not be activated because it triggered a fatal error.
Warning: include(/home/joeysavo/public_html/wp-content/plugins/sitepress-multilingual-cms-/vendor/composer/../../classes/logs/interface-wpml-log.php): failed to open stream: No such file or directory in /home/joeysavo/public_html/wp-content/plugins/events-calendar-pro/vendor/composer/ClassLoader.php on line 444

Warning: include(/home/joeysavo/public_html/wp-content/plugins/sitepress-multilingual-cms-/vendor/composer/../../classes/logs/interface-wpml-log.php): failed to open stream: No such file or directory in /home/joeysavo/public_html/wp-content/plugins/events-calendar-pro/vendor/composer/ClassLoader.php on line 444

Warning: include(): Failed opening '/home/joeysavo/public_html/wp-content/plugins/sitepress-multilingual-cms-/vendor/composer/../../classes/logs/interface-wpml-log.php' for inclusion (include_path='.:/opt/alt/php71/usr/share/pear') in /home/joeysavo/public_html/wp-content/plugins/events-calendar-pro/vendor/composer/ClassLoader.php on line 444

Fatal error: Interface 'WPML_Log' not found in /home/joeysavo/public_html/wp-content/plugins/sitepress-multilingual-cms-/classes/xml-config/class-wpml-config-update-log.php on line 6

August 22, 2019 at 8:38 pm #4442835

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Regarding your issue, please, try the following:

1 - In your WordPress Dashboard > Plugins delete your current WPML Multilingual CMS plugin files and upload a fresh downloaded copy of it from your wpml.org account.

2 - Disable all the plugins and try to activate the WPML Multilingual CMS and run its setup wizard.

3 - Once it is finished activate all the others plugins one by one.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it fixes your issue. Have a nice day.

August 23, 2019 at 1:29 pm #4447609

natalieR-4

My issue is resolved now. Thank you!