Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: America/Los_Angeles (GMT-07:00)

Tagged: 

This topic contains 20 replies, has 2 voices.

Last updated by Bobby 7 months, 4 weeks ago.

Assisted by: Bobby.

Author Posts
September 13, 2023 at 1:42 pm #14390623

tomaszS-53

Hello , I purchased a package for 100$ which is not working .
I used the automatic translation of the page , 90000 credits disappeared , the page barely loads and does not display the fix . The logo itself has changed , the content is still untranslated . What should I do ? I am disappointed with this plugin .

September 14, 2023 at 12:25 am #14392921

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi there,

When I review your ledger on our side I can see that around 90,000 credits were used and I can also see the pages that were translated.

However, when I do visit your site I am not able to see the translations... are the translations possibly pending review and approval?

See the following documentation on how to do this and let me know your results:
https://wpml.org/documentation/automatic-translation/how-to-review-automatic-translations-on-your-site/#:~:text=To%20do%20this%2C%20go%20to,to%20all%20the%20selected%20jobs.&text=Approving%20your%20translation%20reviews%20publishes,front%2Dend%20of%20your%20site.

September 14, 2023 at 7:41 am #14394127

tomaszS-53

Hi
Yes translations are pending , but they are mostly untranslated .
I attach the original home page plus "translated pages"

Pages erroneously display , and 90% are untranslated

Deutch-min.png
September 14, 2023 at 7:42 am #14394199

tomaszS-53

Italy

Itali-min.png
September 14, 2023 at 7:47 am #14394245

tomaszS-53

Original home page

Orginal-min-min.png
September 14, 2023 at 6:16 pm #14399219

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the screenshots! It looks like there is a fatal error possibly breaking the styling.

I would need to see the details of the error log.

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

September 15, 2023 at 8:10 am #14401195

tomaszS-53

[15-Sep-2023 07:55:38 UTC] PHP Notice: Undefined index: Name in /home/serwisdb/domains/karrierevita.com/public_html/wp-content/plugins/js_composer/include/classes/updaters/class-vc-updater.php on line 129

September 15, 2023 at 8:13 am #14401209

tomaszS-53

I don't know if I did it right ?

September 15, 2023 at 8:09 pm #14405413

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

That notice is pointing to the plugin js composer but I dont believe it is enough to cause this behavior.

Are there any other errors possibly logged?

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed It is necessary to take FULL BACKUP of your database and your website. Providing us with access, you agree that a backup has been taken **

I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

September 18, 2023 at 4:43 pm #14414195

tomaszS-53

[removed]

September 18, 2023 at 6:00 pm #14414705

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

Please re-share them in the private field as our forum is public and all sensitive information has been removed and cannot be used due to GDPR laws.

September 21, 2023 at 8:54 pm #14442521

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

I was able to find what was causing this behavior.

- Go to Pages and edit the homepage in Polish (Default language)

- Right click on the language switcher and switch to German ( open in a new tab and dismiss the warning)

Review the page options such as Page Display, Page Title, and Page Layout all three were set wrong for the translation.

After setting them correctly for German it looks like it's displaying correctly now.

hidden link

One way you can do this in an automatic way and save time from having to do this extra step is by setting the custom fields to copy once.

- Go to WPML->Settings->Tłumaczenia pól niestandardowych -> enable "Pokaż metapole „Konfiguracja zawartości wielojęzycznej” na ekranie edycji posta."

- Edit the page again in Polish and scroll to the bottom

- Review the custom fields and set the ones related to these fields to copy or copy once

Let me know your results, please.

September 22, 2023 at 11:53 am #14446917

tomaszS-53

Hi , I don't see any change on the page after changing these three things Page Display, Page Title, and Page Layout.
The page still displays not correctly , the logo is different and the content is still in Polish :/.

September 25, 2023 at 5:11 pm #14461301

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

When reviewing the German page can you please confirm that now the layout is mostly correct?

Regarding the logo where is it currently set? Theme Options? I believe we will have to do the same steps there or use the string translation depending on how it's set.

For the jobs, they will not display unless they are 100% translated and published which is why it's showing no jobs found.

For the translation issue do the following, please:

Go to Pages->Locate the home page and click on + for German.

You will notice only 79% of it finished -> verify that it's correctly translated and save to 100%

Once done it should display the translation as expected

Let me know your results, please.

September 26, 2023 at 11:58 am #14466645

tomaszS-53

Hello, ok I understand .
But how can I translate for example this tab if it does not display in the translations section ?

Screenshot 2023-09-26 at 13-56-36 Agencja Pracy.png

The topic ‘[Closed] Plugin does not translate pages , credits disappeared’ is closed to new replies.