This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 22 replies, has 3 voices.

Last updated by Laura 4 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
October 11, 2018 at 2:41 pm

danielB-41

Hello Team, how are? I need help with a issue with a E-learning plugin and your WPML Multilingual CMS. Is very strange that your plugin doesn't work normally so if can get me some "something set into "WPML Multilingual CMS" plugin affects the way ULP works and the url structure" so i can respond to the developer of the plugin or if you have a quick solution.
Thanks for all!

I am trying to: Use the plugin Ultimate Learning Pro WordPress Plugin (hidden link) and my problem is the following, the quizzes of that plugin are not working, by clicking on “start quiz” it takes me to a post with only the question and does not show anything else, not the timer to perform the quiz, not the answer options, not the hits, nothing only with the SuperAdministrator with the other users just reload and redirect to the main page.

Link to a page where the issue can be seen: hidden link then click on "START QUIZ" button.

I expected to see: The normal Quiz like this video: hidden link i can operated normally with WPML Multilingual CMS deactivated.

Instead, I got: hidden link the page just reload.

The support team of that plugin told me:

We've made an investigation and we've noticed that something set into "WPML Multilingual CMS" plugin affects the way ULP works and the url structure. You can have a short try with the script deactivated.
We didn't made any changes into that script settings but you may want to have a look.

Thanks,
Alex
Indeed Team

October 12, 2018 at 1:55 pm #2812233

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the Ultimate Learning Pro plugin isn't in our compatibility list, so it's possible you're having trouble with it.

From your debug information I see you're using MySQL version 5.5.5, while the minimum requirement for WPML is 5.6 (see here: https://wpml.org/home/minimum-requirements/). You should try asking your server to increase it.
Probably this isn't related to your issue, but we want to rule out any doubt.

then I'd ask you to do this test:
- backup your site
- disable all plugin except Ultimate Learning Pro, WPML, and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme
This is to exclude other plugins from the equation.

If you still have the issue after the test, I'd create a Sandbox site where you can reproduce the issue (installing the plugin etc) and eventually I'll escalate the ticket to the compatibility team.

October 12, 2018 at 3:12 pm #2812398

danielB-41

Hello Laura! thanks for you quick reply!

I will responde by points:

- MySQL version 5.5.5: No, i have MariaDB 10.1 (is like MySQL 5.6) i can update to MariaDB 10.2 but for the "strict mode" i didn't it. You can see better info here: hidden link

then I'd ask you to do this test:
- backup your site (YES) don't worry i have local and external backup.
- disable all plugin except Ultimate Learning Pro, WPML, and its addons (YES, aren't by other plugins)
- switch to a default theme like TwentySeventeen (YES is not the theme)
- check if the issue is happening again (YES, only happend with WPML Multilingual CMS.)
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again (Unfortunately. it Not apply) also I tried with Ultimate Learning Pro + https://wordpress.org/plugins/loco-translate/ and works correctly.
- lastly, reactivate your theme (Unfortunately. it Not apply)
This is to exclude other plugins from the equation.

If you still have the issue after the test, I'd create a Sandbox site where you can reproduce the issue (installing the plugin etc) and eventually I'll escalate the ticket to the compatibility team.

Yes no problem, i can get you the purchase code and the plugin if you want or you cand test on my server. The site is full test mode and i have backups.

Thanks for all Laura!

October 12, 2018 at 4:10 pm #2812595

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if you don't mind I'd use our sandbox service because if I had to configure the plugin you'd have to explain everything to me, to be sure I'm replicating the issue correctly. Sometimes this could be complicated if done by writing.
And second, it's faster because as you can imagine we also have other tickets to take care of, and debugging can take a lot of time.

If it's okay you can use this link to access the sandbox: hidden link and configure WPML + Ultimate Learning Pro as they are on your site. Of course, if you have multiple quizzes and question one or two are enough. Just what is needed to reproduce the issue.

If you'd instead prefer me to work on your server, just let me know and I'll enable a private reply so you can share the credentials with me.

October 12, 2018 at 4:51 pm #2812681

danielB-41

Perfect Laura! i installed the plugin on the sandbox and configured WPML.
Then a replicated the same issue so then i disabled: WPML Multilingual CMS

So if you go to:
hidden link and press click on "START QUIZ" it works correctly.

But if you enable WPML Multilingual CMS, the page hidden link change the content after the footer and when your press click on "START QUIZ" it shows a page to edit.

Thanks for all!

October 15, 2018 at 8:07 am #2816471

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

this really seems a compatibility issue. I wanted to do the last test, to try it with English as a default language (sometimes you have issues with that). I downloaded the plugin but when I try to see a quiz I only see the questions, and the page is different from the one you showed me (see screenshot). What am I missing here?

October 15, 2018 at 9:39 am #2816811

danielB-41

Hi Laura, thanks for all!
Please can you send me again the screenshot. I'm on th sandbox to try the scenario that you told me: the main language set on english.

October 15, 2018 at 9:55 am #2816908

danielB-41

Hi Laura, recently i tried that scenario but i have the same result.

I only replicated this:
"WPML Multilingual CMS" plugin affects the way ULP works and the url structure." recently i saw that the URL change when WPML Multilingual CMS is enable or disable:

hidden link

Maybe some settings to verify that not affect that will work perfect, thanks for all!

October 15, 2018 at 10:34 am #2816988

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

here is the screenshot again.

I suppose you changed the default language in WPML -> Language, but in such cases, it's better to test on a fresh installation, that's why I was trying on my local server.
Or at least trying to reset WPML.

Thanks for the video, this is a useful information.

October 15, 2018 at 4:51 pm #2818356

danielB-41

Thanks for all Laura,

so you will continue investigating this case? Thanks!

October 16, 2018 at 7:50 am #2819987

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we'll look better at this issue, but I have first to understand how to reproduce it. Do you have any suggestion on why I'm not seeing the quizzes in my local install? I only need to check this and then I can pass the ticket to the compatibility team.

October 16, 2018 at 11:50 am #2820809

danielB-41

Hi Laura, if you refer to the capture when you said " I'm not seeing the quizzes " that happened because "WPML Multilingual CMS" is enabled if you disable then you will see the quiz normally.
Thanks for all!

October 16, 2018 at 5:33 pm #2821999

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

WPML is not active on that site, I didn't even configure it. That's why I am perplexed.
Anyway, mine was an extra control, from the sandbox we can clearly see there is an issue, so I escalated the ticket.

October 19, 2018 at 5:04 pm #2832753

danielB-41

Hi Laura, how are you? can you tell me if you have any update about this case.

Thanks a lot!

October 22, 2018 at 8:01 am #2837053

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I have no news yet. I'll update you as soon as possible.