This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 24, 2019 at 11:36 am #3672179

aksars

I am trying to: register and enable ATE

Link to a page where the issue can be seen:dashboard

I expected to see:

Instead, I got:

April 24, 2019 at 12:19 pm #3672621

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Your question is not clear enough.

Could you please explain your issue with screenshots for better understanding.

Regards,
Riffaz.

April 24, 2019 at 12:21 pm #3672633

aksars

when i try to register the plugin its not getting registered.

April 24, 2019 at 12:29 pm #3672703

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please refer : https://wpml.org/forums/topic/invalid-key-error-3/#post-3265703

Let me know how it goes.

Regards,

April 24, 2019 at 1:05 pm #3673227

aksars

I did the same and still have the same issue. image attached.

April 24, 2019 at 1:26 pm #3673397

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

As per your last screenshot your hosting is blocking admin-ajax.php file.
Please contact your hosting provider support and show this screenshot.
They will be able to fix it in minutes.

Let me know how it goes.

Regards,

April 24, 2019 at 2:51 pm #3674343

aksars

I am not using any hosting provider. i am in a corporate network. you mean is this being blocked by our company firewall? if so, can you please explain me more to contact my network team with proper details.

April 25, 2019 at 6:47 am #3679187

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ask your network team to check the error log.

Also,
Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

April 25, 2019 at 7:30 am #3679523

aksars

Debug logs below:

[24-Apr-2019 13:06:52 UTC] PHP Fatal error: Uncaught OTGS_Installer_Fetch_Subscription_Exception: User has blocked requests through HTTP. in /app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/site-key/class-otgs-installer-fetch-subscription.php:129
Stack trace:
#0 /app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/site-key/class-otgs-installer-site-key-ajax.php(40): OTGS_Installer_Fetch_Subscription->get('wpml', 'zPrG9Ucl3Q', 3)
#1 /app/public/wp-includes/class-wp-hook.php(286): OTGS_Installer_Site_Key_Ajax->save('')
#2 /app/public/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /app/public/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#4 /app/public/wp-admin/admin-ajax.php(167): do_action('wp_ajax_save_si...')
#5 {main}
thrown in /app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/site-key/class-otgs-installer-fetch-subscription.php on line 129

April 25, 2019 at 1:29 pm #3682767

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

It looks that your server is blocking WPML/OTGS requests related with the validation of the subscription to be sent.
So the problem is that your site is not being able to register the site key as the connection that is made is being blocked.

Please contact your hosting company and ask them to check the server.
Also, show the error message you are getting.

They will be able to fix this in minutes.

Regards,

April 25, 2019 at 1:43 pm #3682915

aksars

I am not using any hosting provider. i am in a corporate network. you mean is this being blocked by our company firewall? if so, can you please explain me more to contact my network team with proper details.

April 26, 2019 at 9:52 am #3689339

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

hi,

You can just point them this PHP Fatal error: Uncaught OTGS_Installer_Fetch_Subscription_Exception: User has blocked requests through HTTP

They will understand and fix this.

Regards,

May 1, 2019 at 7:54 am #3716725

aksars

they are not aware of the issue. somehow i only have to guide them. Below are the logs i got for WPML. Is this that you have to do from your side?

-------------------

05/01/2019 07:26:05 am - call - //tp.wpml.org/services.json - {"api_version":1.1}
05/01/2019 07:26:06 am - error - Cannot communicate with the remote service | url: `//tp.wpml.org/services.json` method: `GET` param: `{"method":"GET","sslverify":true,"timeout":60,"headers":"Content-type: application\/json"}` response: `{"errors":{"http_request_failed":["cURL error 60: Peer's certificate issuer has been marked as not trusted by the user."]},"error_data":[]}`

May 5, 2019 at 4:26 pm #3743539

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Simply your server/network blocks the access to wpml site.

Ask them at least to whitelist our servers

api.wpml.org with IP 74.50.57.129 and
wpml.org with IP 74.50.57.118.

Also whitelist cloud front with

d2salfytceyqoe.cloudfront.net

Then check the issue.

You will not experience this in a common server.
If you want I can setup a test site your site content where you can check this.

Let me know how it goes.

Regards,

The topic ‘[Closed] plugin misbehaving’ is closed to new replies.