We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mihai Apetrei 4 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 9, 2019 at 1:56 pm #4171467

tessaB-2

I am trying to: Make the plugin work

Link to a page where the issue can be seen: Not there since the plugin is not showing. The photo is the ftp where I uploaded the plugin.

I expected to see: The plugin

Instead, I got: Nothing

July 9, 2019 at 3:59 pm #4172881

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please elaborate a bit more on what is exactly you are trying to accomplish and what is not working?

From my understanding, you are trying to upload the WPML plugin via FTP instead of installing it from inside the WordPress panel so in order to do that, you should download our plugin from your WPML.org account and then extract the zip archive and add the contents of it (you will see that the files are found inside a "sitepress-multilingual-cms" folder) into "wp-content/plugins".

So the files of the WPML plugin should be "seated" inside "wp-content/plugins/sitepress-multilingual-cms". From your screenshot, I see that there are a lot of files inside "wp-content/plugins/" instead of "wp-content/plugins/sitepress-multilingual-cms".

Please let me know how that goes.

If you can't still do it, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 10, 2019 at 3:46 pm #4182261

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

So from what I see there are 2 WordPress setups on your server and both of them were missing the folders you mentioned, so I added them (I will also attach some screenshots so that you can see the FTP structure.

So I added them and they should normally show up in the backend of WordPress panel > Plugins. They should be disabled by default and you should be able to see them and enable them.

However, I don't see them still on your site and this is very weird.

I strongly suggest that you get in touch with your hosting provider and see why this is happening - practically WordPress is not able to see any new folders that are added to the /plugins directory.

Can you please let me know what answer you get from them?

This is the first time I encounter something like that so if you get any solution, that might be helpful for other people to see, too, that might find themselves in the same situation.

Thank you so much and I will be waiting for your response.

PS: One other thing is that you might see a cached version so making a backup of your site and then disable all the non-WPML plugins to see if the issue is still happening might be useful.

Kind regards,
Mihai

July 11, 2019 at 11:52 am #4189427

tessaB-2

Hi,

Ok so I called My hosting provided. I explained the situation. They asked me why I couldn't upload through wp back-end. I said it was because the file was too large. So they made the upload-able memory higher and asked me to install the plugin again through the back-end of wp. Then it gave me this error: PCLZIP_ERR_BAD_FORMAT (-10)

I told them and they told me to reach out to you again. What's the next step? 🙂

Regards,
Tessa

July 11, 2019 at 5:01 pm #4192129

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am glad to hear that we are making progress.

I was able to go to your site's backend and install the plugins (WPML + WPML Translation Management).

I will also attach a screenshot (you can see the plugins installed here: hidden link).

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai