This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Andreas W. 2 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
July 3, 2019 at 2:47 pm

thomasG-78

We have your Plugin "WooCommerce Multilingual" installed on a clients website which serves customers from Germany and Switzerland (EUR and CHF).

We also use a Plugin from Saferpay to manage credit card payments (VISA and Mastercard).
Whenever we activate your plugin, Saferpay somehow redirects users to PayPal instead of their VISA/Mastercard workflow. When we deactivate your plugin, the redirects are correct again.

Here is a screen capture video of our current settings: hidden link

Here is the original thread from wordpress.com: https://wordpress.org/support/topic/plugin-overwrites-redirect-url-for-saferpay/

Thanks,
David

July 4, 2019 at 12:24 am #4139369

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Before taking any further steps please update WPML and its add-o9ns ot the latest version.

Go to Plugins -> Add new -> Commercial and click "Search for Updates". Now complete with the downloads and activate the plugins.

Also make sure that any other plugin is up-to-date.

Now, please verify if the issue still persists.

If it does, please install the plugin WooCommerce SaferpayCw onto the following test site and recreate the issue on this new WordPress install.

One Click Login: hidden link

Let me know about the outcome in order to further assist you.

Kind regards
Andreas

July 4, 2019 at 11:17 am #4142689

thomasG-78

Hey Andreas,

thanks. I updated all plugins and also the theme to their newest version. The problem still persists though.

I also installed the Saferpay Plugin to your sandbox account. However, we will not be able to reconstruct the whole site and functionality since originally, it is working with two different domains.

Please also keep in mind, that the checkout via Saferpay is working 100% correctly when testing on our main domain "ibes.ch". The issue only occurs when a user is checking out via our secondary domain "ibes-gegen-elektrosmog.de" which is setup via WPML and custom DNS entries.

Reconstructing the issue on a single domain sandbox will not help with reconstructing the issue.

However when logged in, you can download our newest Duplicator archive of the website from here:

- hidden link

You can also refer to your colleague "George Botsev" who already had a rough feeling for what might be causing the issue: https://wordpress.org/support/topic/plugin-overwrites-redirect-url-for-saferpay/

Kind regards
David Maucher

July 5, 2019 at 5:00 pm #4152965

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I understand that the issue occurs when WPML is activated but it mightbe that this is even caused due to incoatibility with a different plugin.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not WooCommerce, WooCommerce SaferpayCw and the WooCommerce Payment Gateways, and WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

How doe sit behave if you change to a default theme like TwentyNineteen?

Further, enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

In case of errors, you will be able to find a complete report inside of your wp-content folder. Make sure to visit your site´s Front_End and Backend for a while in order for WordPress to locate the errors. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

I will setup a local enviornment with WPML and Domains per Language. Please provide me a download link to the WooCommerce SaferpayCw plugin for further testing.

Private reply is enabled.

Kind regards
Andreas

July 9, 2019 at 2:43 pm
July 9, 2019 at 10:16 pm
July 9, 2019 at 10:17 pm #4174613

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just send you a private message with informations for migrating your website to our test server.

Please make sure to leave me a short message once the site migration is completed.

Kind regards
Andreas

July 11, 2019 at 9:27 am #4187903

thomasG-78

Hey,

we tried your cloudways migration process but after about 20 minutes, we received this email:

"Oh no! It seems a problem has occurred while migrating your site to Cloudways. We apologize for any inconvenience this may have caused.

Kindly contact us as soon as possible via live chat for a satisfactory resolution of the problem.

Sincerely,
The Cloudways Team"

Can't you just log into our site and download our newest Duplicator files and install them on cloudways?

Thanks
David

July 11, 2019 at 7:07 pm #4192789

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

It seems the migration failed due to a database issue. From this point I can not tell if the issue is related to your site' s database or to a failed migration process.

I tried to repair the database by adding the following line into the wp-config.php file:

define('WP_DEBUG', true);

Sadly the repair failed. There are various databse issue inlcuding core WordPress table. As far I did not see anz database issue in regards to WPML.

I would advise you to enable the wp-debug feature on your live site and investigate the issue yourself.

To enable the feature please read the following documentation:
https://wpml.org/documentation/support/debugging-wpml/

The earlier provided copy of the the plugin WooCommerce SaferpayCw is sadly not able to be installed. Could it be that you have taken here a copy from you wp-content/plugins folder?

Please install a new version of the plugin on the following test site to recreate the issue and test the plugin for compatilbity with WPML and WooCommerce Multilingual.

One-Click-Login: hidden link

Leave me a short notification once the plugin is installed.

Kind regards
Andreas

July 12, 2019 at 11:17 am #4198027

thomasG-78

Hey,

why do you keep on ignoring my Duplicator archive? Just log in our site, download it and install it on your server. Should take no more than 20 minutes, right? Instead, we are talking around since July 3rd now and have nothing found yet.

Your one-click-login also does not work...

Thanks
David

July 12, 2019 at 2:31 pm #4199793

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I will try to migrate the Duplicator package to our test server and let you know about the outcome.

Anyhow, based on your explaination it seems to me that there is a compatibility issue between WPML and the plugin WooCommerce SaferpayCw. The plugin firther has until now not been tested with WPML.

I would like to ask you again to install the latest version of the plugin on the following test site.

One Click Login: hidden link

This procedure is requiered in order to investigate and escalate the issue to our compatilbilty team.

Please leave me a short notification once the plugin is installed.

Kind regards
Andreas

July 12, 2019 at 2:35 pm #4199863

thomasG-78

Hey,

thanks... I installed the plugin on your server.

Thanks
David

July 12, 2019 at 6:56 pm #4201231

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

I have tested the plugin on a new install without receiving errors. I also took a copy of your site and migrated it to our test server.

I then tested on your live site while trzing to make purchases. I am not able not see any issue about a false redirect to PayPal when trying to pay with with Visa.

When trying to make a purchase on your live site using Visa I receive on both languages an error: "Die Zahlung konnte nicht verarbeitet werden."

I receive the same error when disabling WPML and all its add-ons.
"The payment could not be processed."

Further, as far I can see that there are errors in the debug.log but in order to investigate the issue and its realation ot WPML or WooCommerce Multilingual I will need to know how far it does have impact on the site. What exactly is not working with the translation?

Could you please verify and clarify at what point of translating the issue is causing problems?

Kind regards
Andreas

July 16, 2019 at 2:34 pm #4221105

thomasG-78

Hey Andreas,

thanks for investigating this.

Please watch this screen record: hidden link
... and keep in mind, we have two different domains:

- ibes.ch - for customers from Switzerland
- ibes-gegen-elektrosmog.de for customers from Germany

The error "Die Zahlung konnte nicht verarbeitet werden." should only ocurr when the transaction is interupted by a user.

Again, this is the problem:

When a user tries to checkout via VISA or Mastercard on ibes.ch, everything's fine.

When a user tries to checkout via VISA or Mastercard on ibes-gegen-elektrosmog.de, he get's redirected to Saferpay which then redirects him to PayPal. This should not be the case.

The behaviour only occurs when WooCommerce, WPML and your plugin are active together.
As soon as we deactivate "WooCommerce Multilingual", everything's fine.

So it's pretty obvious to me that your plugin somehow seems to change parameters in the request.

Thanks
David

July 17, 2019 at 4:07 pm #4232075

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please have alook into the following errata and apply the fix to the respective file:

https://wpml.org/errata/woocommerce-with-multiple-currencies-triggers-a-call-to-get_cart-too-early/

On the migrated test site this fix solved the exisiting errors and the payment gateways should get redirected as expected.

Let me know if you need further assistance.

Kind regards
Andreas