This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Updating WPML 4.2.5 shows 500 Error on plugins.php

Solution: Go to Dashboard -> Updates Press the "Check again" button Scroll to the bottom and press the "Update" button Go to the Plugins page

Relevant Documentation: Update for WPML 4.2.6 solved the issue. https://wpml.org/2019/04/wpml-4-2-6-faster-string-translation-for-busy-sites/

This topic contains 7 replies, has 2 voices.

Last updated by heikoT 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 10, 2019 at 6:23 pm #3580291

heikoT

Dear support,

Just wanted to update the WPML plugin, but the plugin page just shows me an error.
I already tried to download the newest version, deleted the WPML directory and uploaded it new - without success.
Since I can not access the plugin page, I can't deactivate/delete it there.
The WPML functionality if our whole website is down, can't switch languages any longer.

I know that the plugin page worked some days ago, not sure since when this problem is.

The error:

Fatal error: Uncaught Error: Call to a member function get_external_repo() on null in /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php:2335 Stack trace: #0 /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-includes/class-wp-hook.php(286): WP_Installer->setup_plugins_page_notices('') #1 /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-admin/admin-header.php(276): do_action('admin_notices') #4 /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-admin/plugins.php(459): require_once('/kunden/89696_9...') #5 {main} thrown in /kunden/89696_90408/rp-hosting/10022/10525/webseite/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2335

April 10, 2019 at 7:00 pm #3580509

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue has been escalated to our Developer Team.

In the meantime we were able to find a solution.

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button
Go to the Plugins page

Let me know if this solved the issue.

Kind regards
Andreas

April 10, 2019 at 7:11 pm #3580635

heikoT

Hi Andreas,

Thanks for your fast answer.
Yes, I can access the Plugins page without errors now.
WPML is still not working on our website / I did not press the update button on the plugin page - wanted to wait for your further instructions.

Cheers
Heiko

April 17, 2019 at 5:38 pm #3634079

heikoT

Hi guys,

Is there already a solution? Our website shows currently just the main language - all other languages are not working.

Thanks
Heiko

April 24, 2019 at 10:46 pm #3677423

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Good news!

We have just released WPML 4.2.6 and updates for various add-ons. Could you please update your plugins by going to Plugins -> Add new -> Commercial.

Let me know if you need any further assistance or please feel free to mark this ticket as resolved.

Thank you!

Kind regards
Andreas

April 29, 2019 at 6:14 pm #3705977

heikoT

Thank you. After changing some more settings, our website is back working. Thank you - the ticket can be closed.

Cheers
Heiko

April 29, 2019 at 9:36 pm #3706719

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for the notification.

Have an nice day!

Kind regards
Andreas

May 2, 2019 at 1:38 pm #3724967

heikoT

My issue is resolved now. Thank you!