This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by sarahT-6 3 months ago.

Assigned support staff: Bobby.

Author Posts
July 15, 2019 at 8:29 pm #4214533

sarahT-6

I am trying to translate the filter dropdowns on this page: hidden link

I was on a chat with someone from your team and they could not figure it out.

The strings for this plugin do not show up in the translate strings section.

Im using this plugin: hidden link

July 15, 2019 at 11:59 pm #4214811

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

are you referring to the dropdown in my screenshot?

how are you currently adding these filter dropdowns? Are you adding them through the admin options ?

also is gridbuilder your page builder or the plugin for the filter?

for a string to show up in the String Translation the hardcoded strings need to be wrapped in a gettext call https://wpml.org/faq/language-setup/ or if they are added in the admin screens you could find them within WPML->String Translation->Translate string in admin screens (bottom of the screen)

if you provide me with some additional information i will be able to tell which way the strings are being added to better determine how we can translate them

also do note that there is a possibility the strings are not translatable yet as the plugin is not currently listed as compatible with WPML but i will be able to get a better idea once i know how the strings are added https://wpml.org/documentation/plugins-compatibility/

July 16, 2019 at 2:41 pm #4221137

sarahT-6

Ya the all the dropdown on this site are not being translated. I am adding the placeholders by going to gridbuilder -> facets -> behaviour -> placeholder.

Gridbuilder is a plugin.

Do you need the credentials to see? Would it be better to just code it myself instead of using this plugin?

July 16, 2019 at 3:36 pm #4221937

sarahT-6

Also, is there a list of compatible plugins. Perhaps there is another one we can use?

July 16, 2019 at 4:24 pm #4222291

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

As long as you are adding these placeholder through your plugin's options page we should be able to register them with wpml-config.xml

=> https://wpml.org/documentation/support/language-configuration-files/

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

NOTE : regarding the list of compatible plugins please find it here
https://wpml.org/documentation/plugins-compatibility/

Thank you,
Bobby

July 16, 2019 at 5:15 pm #4222625

sarahT-6

Ok I generated an offsite backup. Here are the credentials:

[removed]

If you go to string translation, strings from that plugin are under: wp-grid-builder
but of course the placeholder strings aren't there.

July 16, 2019 at 6:42 pm #4223305

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

you can find them listed under WPML->String Translation->Translate strings in admin screens -> cptui_post_types and cptui_taxonomies

i've added most of them within your String translation dashboard , if any are missing you should be able to find them now and add them as well

let me know your results

July 16, 2019 at 7:18 pm #4223441

sarahT-6

I tested this out with Publication Type and it's still not translated here: hidden link

July 17, 2019 at 3:57 pm #4232029

sarahT-6

Hi, Any update on this?

July 17, 2019 at 5:09 pm #4232483

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i am not able to review the backend anymore as the credentials are no longer working , if possible please renew them and update me here

July 17, 2019 at 10:49 pm #4233745

sarahT-6

In the meantime I'm making a custom template but posts from both languages are showing and the custom taxonomies are not showing on the french side. Is there documentation for things like this?

July 18, 2019 at 5:18 pm #4241389

sarahT-6

Can someone please help me? I can't keep the client waiting like this.

July 18, 2019 at 9:54 pm #4242471

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

When i visit hidden link i can see the Publication Type translated as expected.

to translate taxonomies and their names you can do it directly through WPML->Taxonomies Translation

but the translation of Publication Type on the page here is coming from the theme-text-domain in String translation (screenshot)

hidden link

apart from grid builder how are you adding the taxonomies ex. Publication Type , Country , etc.

i can see that you are using a custom theme?

our official documentation on translation of custom taxonomies -:> https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

July 19, 2019 at 1:39 pm #4246759

sarahT-6

No Screenshot was attached to this.

I'm using elementor and a plugin called wp grid builder but I just tried making my own loop cause the solution you provided doesn't work for the grid builder.

hidden link

This page works except the placeholders. Do you have anything else I can try for the placeholders?

July 19, 2019 at 8:47 pm #4248137

sarahT-6

I think I figured it out. Some of the custom taxonomies are now showing on the dashboard when I go to edit a post on the french backend. What can I do to fix this?