This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by thorstenR-2 9 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 20, 2019 at 3:58 pm #4613431


I am trying to:
I want a translated version of my popup. I am using a button (contact) to open the popup.
I have translated the popup and have checked the string translation. Everything shows up fine. But on the live website the popup is not showing the translation english, but the native language german.

Link to a page where the issue can be seen:
hidden link

I expected to see: english translation

Instead, I got: german original

September 20, 2019 at 4:33 pm #4613593


I tried to enable Ajax, but that didnt help.

I am using Elementor Pro to create the popup.

September 20, 2019 at 4:46 pm #4613667


Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I see that this issue has been escalated to our developers. I have escalated this ticket as well. In the meantime, as a workaround, you can try this:

1. save Popup content in a template;
2. translate the template content;
3. insert "template widget" in popup and include your previously saved (and translated) template."


September 20, 2019 at 5:40 pm #4613917


Thank you Lauren, saved my day!
My issue is resolved now. Thank you!
Hope this will be fixed with a future update!

November 9, 2019 at 3:45 pm #4918599


No, doesn't work for me. It's still the default language popup which is showing up. Really bad as it is the most important CTA on the whole website ...