This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Noman 3 months, 4 weeks ago.

Assigned support staff: Noman.

Author Posts
June 9, 2019 at 9:18 pm #3983697

nomad-cphA

I am trying to: Translate the portfolio, on our page called 'Travel Secrets': hidden link to the Danish version hidden link

I've used WPBakery to create a text box for a description before the portfolio tiles. I have tried to translate using both the WPML translation editor and using the standard editor and neither are working.. see attached screenshots. I also tried looking for the text in String translations and translated it there, but still isn't work. Any idea how I can get this text translated into Danish? The text should be:

Vi vil gerne inspirere dig til at tage ud og se verden. Der er så mange smukke og unikke steder og nogle af vores personlige favoritter vil vi dele med dig gennem vores Travel Secrets.
Nomad Travel Secrets vil blive opdateret hver uge med nye lækre steder at besøge over hele verden.
Go explore! Vi vil også meget gerne høre om dine rejseeventyr eller se billeder - @nomadcph_ // #nomadcph

Thanks so much for your help!

Best

June 10, 2019 at 6:52 am #3985431

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Here are WPBakery Page Builder modules that are supported by WPML and will automatically be displayed on the Translator Editor page:
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/#supported-modules

And here is a guide how to make custom VC element WPML translation editor compatible:
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
https://wpml.org/documentation/support/language-configuration-files/

Please let me know if this resolves your issue or you need further assistance.

Thank you

June 12, 2019 at 10:19 pm #4007831

nomad-cphA

Hi! Thanks for your reply. I increase the WP memory as you said, and the problem with this page is still there. It is a standard text box element from WPBakery Page Builder, so it shouldn't be a problem.. it is still showing up the same way as I showed you in the screenshots.

Any other ideas? Thanks for your help, best,

Jeff

June 13, 2019 at 5:28 am #4009527

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please try below steps and let me know how it goes?
- Edit the translation and finish it as it is (mark it as 100% Translated).
- Make a small change in the original page, for example, a space in your title.
- Edit the translation again.

Does it work this time? If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 18, 2019 at 9:59 am #4042357

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and opened 'Travel Secrets' page in translation editor and it showing all fields as you can see in the attached screenshot.
hidden link

Could you please clear your browser cache and take another look on it.

Thank you

June 18, 2019 at 10:04 am #4042475

nomad-cphA

Right, in the backend it looks like it should work (the only thing I have left in English is the yoast seo area, the rest which should display in Danish here: hidden link
is not.

That's the big problem...

Please let me know, thanks!

Jeff

June 19, 2019 at 6:54 am #4048461

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

FTP login info that you have provided is not working here also File Manager plugin is not working in your site.

Could you please try below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

After adding the above code please try to reproduce the issue and this will create debug.log file in your site's wp-content directory. Please send me its contents.

If still issue persists, please provide me working FTP. I have enabled private input box for your next reply.

Thank you

The topic ‘[Closed] Portfolio description not translating’ is closed to new replies.