This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Unable to translate the portfolio extra content in Salient theme.

Solution: WPML > Settings > Custom Fields Translation and set 'Show system fields'

Then search for '_nectar_portfolio_extra_content' and set it to 'Translate'. Then make a change to the original portfolio item and then go into the translation for it, and the field now appears for translation.

This topic contains 10 replies, has 2 voices.

Last updated by janeT-2 3 weeks, 2 days ago.

Assigned support staff: Riffaz.

Author Posts
April 19, 2019 at 10:57 am #3645147

janeT-2

I am trying to: translate the 'extra content' field of the portfolio items

I expected to see: the 'extra content' section available for translation

Instead, I got: the other fields (title, body, excerpt) but not that one

The other portfolio details are available for translation and we have successfully translated those, so the portfolio items are setup as translatable. Just that one field doesn't appear.

I searched online and found a bit of custom XML to try and make it appear so added that in, but it didn't seem to help in my case:
<wpml-config>
<custom-fields>
<custom-field action="translate">_nectar_portfolio_extra_content</custom-field>
</custom-fields>
</wpml-config>

Thanks

Jane

April 19, 2019 at 1:14 pm #3645923

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Do you see this custom field in WPML > Settings > Custom Fields Translation ?

If yes, make it translatable there and check the issue.

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

April 19, 2019 at 7:46 pm #3648125

janeT-2

Hi

When I search the Custom Fields Translation for 'nectar', 4 other fields come up, but not one to do with the extra content I don't think.

I'm not adding the login details as this doesn't look like the form on my previous ticket which stated it was private. Can you please confirm if this is indeed private and I will add the login details for you.

Thanks

Jane

April 22, 2019 at 5:00 am #3653921

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The next reply is private.

Regards,

April 23, 2019 at 6:17 am #3659727

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I see this can be translated hidden link here hidden link after I scanned theme and plugins in WPML > Theme and plugin localization but still this is unable to be translated : hidden link

Actually that is an iFrame hidden link which is a custom work of your theme.
Did you check this with your theme support?

Please get back to us after checking this with your theme.

Regards,

April 23, 2019 at 10:57 am #3662399

janeT-2

Hi. Thanks for looking. As you say, the instructions text ('Please use this section to place any extra content you would like to appear...') can be translated, but not the actual content of the field, which is what I need.

When I inspect the page, it seems that the iframes are just used to house the WYSIWYG editor. As the one you inspected has an ID of "_nectar_portfolio_extra_content"

<body id="tinymce" class="mce-content-body _nectar_portfolio_extra_content post-type-portfolio post-status-publish page-template-default locale-en-us mceContentBody wp-editor html5-captions" data-id="_nectar_portfolio_extra_content" contenteditable="true">

And if you look a little further up the page there is another WYSIWYG editor area called "content" which has very similar html

<body id="tinymce" class="mce-content-body content post-type-portfolio post-status-publish page-template-default locale-en-us mceContentBody wp-editor wp-autoresize html5-captions" data-id="content" style="overflow-y: hidden;" contenteditable="true">

But this content is available to be translated into other languages.

So it seems to be an incompatibility between WPML and the theme. I assume this field just hasn't been made available for translation?

Would it be possible for you to work with the Salient developers, as presumably this should be translatable for the theme to be classed as fully compatible? In my other ticket, when an incompatibility was found, the developers provided a short term fix until the next theme release, and hopefully they can do the same this time.

Many thanks

Jane

April 23, 2019 at 11:29 am #3662959

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We need to check this in a fresh installation to make sure the compatible issue.
Then it will be easier to troubleshoot and to provide a workaround.

please,
1. go to hidden link
2. install your theme
3. configure the WPML as you have it on your site. at the last step just click next (site key)
4. create only one portfolio
5. translate it.
6. recreate the issue.
7. let us know how to check this and how to recreate this issue.
8. explain the step 8 with screenshots and URLs for better understanding.

Regards,

April 24, 2019 at 9:12 am #3670817

janeT-2

Hi

Thanks. I have installed the theme and setup WPML and the problem does still persist in the sandbox setup.

To recreate the issue:
1) enter the portfolio section and click to edit the portfolio item (In the main language of English) - hidden link

2) the second editable html block is called 'Extra Content' (screenshot extra-content-english.png)

3) the content added here appears on the single portfolio page hidden link

4) then go back to the portfolio list in admin and click the Danish translation (screenshot danish-link.png)

5) fields are available for translation (screenshot portfolio-item-danish.png) - Title, Body, Project Category and Custom Fields. But the 'Extra Content' html block does not appear, so cannot be translated.

Many thanks

Jane

April 24, 2019 at 11:23 am #3672063

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you so much for this.

I escalated this to our compatibility team.
Please be patient till we get back to you.

Regards,

April 28, 2019 at 7:06 am #3697269

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Now it's translatable in the test site: hidden link
The reason was the custom field

_nectar_portfolio_extra_content

is set to copy-once and on our testing servers it's set to translate.

Please set it to Translate in WPML -> settings (you will need to click "Show system fields" : hidden link ) then you'll be able to translate the Extra content.

Let me know how it goes.

Regards,
Riffaz.

April 29, 2019 at 1:39 pm #3703899

janeT-2

Thanks, I have replicated this on my own site and the field is now translatable.

Some more instructions for anyone else finding this once the screenshots have disappeared, go to

WPML > Settings > Custom Fields Translation and set 'Show system fields'

Then search for '_nectar_portfolio_extra_content' and set it to 'Translate'.
Then make a change to the original portfolio item and then go into the translation for it, and the field now appears for translation.

Many thanks

Jane