This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 5 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 22, 2019 at 1:17 pm #3655837

xavierM-22

Hi,

Portfolio only appears in the main language portfolio page, not in the translated ones. We double check page configuration and all three pages (original and translated ones) share the same: main page, portfolio page template...

So: main language portfolio page set as home page shows all portfolio items fine but them are not displayed in the translated ones, both configured in the same way.

Any idea on what may be wrong?

Thanks again!

April 22, 2019 at 4:44 pm #3657085

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know if you were able to follow the exact steps from the documentation here: https://wpml.org/documentation/theme-compatibility/translating-kalium-theme-using-wpml/#translating-portfolios

If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 23, 2019 at 3:37 pm #3665753

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

I can also confirm that the credentials are working properly.

I will need to spend some more time on debugging this and I will get back to you as soon as I have more feedback.

Kind regards,
Mihai

April 25, 2019 at 8:29 am #3680087

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what can I see, the portfolios are translated well and they do work if we access the links individually:

- default lang: hidden link
- spanish: hidden link
- english: hidden link

However, when the portfolio template page is used, somehow the code that is generated doesn't find/generate the content.

I ran a few tests after I created this page, too: hidden link

It seems that it still doesn't work.

However, from what I can see, you are not using the default Portfolio functionality that comes with the Kalium theme but instead, you are using a plugin called "Portfolio Post Type" and I can't find that plugin in our official WPML-compatible plugin list here: https://wpml.org/documentation/plugins-compatibility

1. Can you please let me know if the "Portfolio Post Type" is required by the Kalium theme developers? Or you installed it separately?

2. Also, as I was mentioning above, I can see that the homepage is using the "Portfolio" page template and again, I don't know if that comes with the Kalium theme or if was added extra.

Now please try this:

a. Please create a full website backup first (files + database) and then go here (hidden link) and update all the WPML plugins to the latest version.

Please now check to see if anything changed.

b. If that doesn't change anything, you could try disabling all the extra plugins and leave just the necessary ones + WPML ones and see if the issue is still happening.

c. Something else that you can do is activate the debugging mode.

This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log and send it to me

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

My guess is that we might be dealing with a compatibility issue so if nothing from the steps above make things work, we will need to replicate the issue on a clean-install sandbox on our servers and if the issue will still happen, I will then be able to forward this to our compatibility department for a closer look.

I will be waiting to hear from you to see how things are going and if you are able to find anything new.

Kind regards,
Mihai

April 25, 2019 at 9:58 am #3680841

xavierM-22

Hi Mihai,

thanks for writting!

I've just tried to update all plugins and deactivate those not required. By doing that I identified that the problem is with Portfolio Post Type plugin which is installed with Kalium by default (it seems to add portfolio custom post type and taxonomies without any style associated). When I deactivate it the main page of three languages display all the created portfolio items but all of theme get the same error when clicked: nothing appears to be there until I activate the plugin again. When activated, only the main language display the portfolio items.

I activated debug mode but nothing appears in wp-content/ folder yet.

Any idea on how to proceed?

Xavier

April 25, 2019 at 9:23 pm #3685981

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

I am happy to see that we are making progress.

That sounds to me like a compatibility issue.

In this case, the normal process is that I will set up a clean sandbox testing environment for you (where we will have installed only the WPML plugins + the theme that you are using and the plugins that are needed to accomplish the portfolio functionality) and I will need you to try to replicate the issue.

If the issue will happen on our servers, too, in a clean install environment, then that might confirm that this is a compatibility issue and that will allow me to forward this issue to our compatibility department.

I created this sandbox for you here (one-click login):
hidden link

I already set up WPML with the same languages you had configured on your site so that it will take less time for you to do what I really need you to do and that is this: I need you to just install the theme and the plugins that are needed to replicate the issue and then try to replicate the issue.

Please let me know when that's done and if it's still happening on our servers, too.

Kind regards,
Mihai

The topic ‘[Closed] Portfolio only appears in the main language portfolio page, not in the translated ones in Kalium theme’ is closed to new replies.