Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.73 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: After full translation in french and small changes, no portfolio posts will be displayed anymore.

Solution: The cause of the issue was that the slugs of the porfolio weren't translated. I translated the slug to French in WPML -> Settings -> Post Types Translation

Relevant Documentation:

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by markusS-65 3 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 29, 2019 at 12:13 pm #4480677

markusS-65

Hello,
after full translation in french and small changes, no portfolio posts will be displayed anymore. In the backend everything is visible but as soon as you go the direct link a 404 error appears.
The difference lies between moosmoos.de and moosmoos.fr .fr does not work.

Is it possible to renew the "linkage" between the German Portfolio Post and the French?

Many thanks for the support

August 29, 2019 at 12:44 pm #4480951

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Go to WPML -> Languages -> Language URL Format -> Select the last option -> Save the changes -> Re-save the permalink structure.

If the issue disappeared then please visit this link and make sure the configuration of the .fr domain is correct: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

If the issue persists then go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps highlighted in the attached image.

Could you tell me the results of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

August 29, 2019 at 1:39 pm #4481427

markusS-65

Unfortunately, it does not work to one hundred percent, but I think I have found the mistake. If I save the language URL format (a different domain per language) in the .de admin panel everything works on the .de domain. The same with .fr

Strange that all pages work but no portfolio entries.

where is the error now?

August 29, 2019 at 1:50 pm #4481491

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

I can't give you an answer with this information. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 30, 2019 at 8:58 am #4485443

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for the information provided.

Before I start isolating the issue I kindly ask you to update the outdated plugins and themes and double check if the issue persists.

This way we can rule out some possible issue already fixed in the newest versions as the cause of the issue.

Regards,
Carlos

August 30, 2019 at 9:25 am #4485707

markusS-65

hi,
Updated all plugins and themes. Unfortunately still no success. I hope we can solve the problem quickly! Thank you for your support.

August 30, 2019 at 10:31 am #4486381

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you for your feedback.

I applied several tests in the site and it seems that the cause of the issue is not related to the domains, but to an incompatibility or maybe a custom change. I went to WPML -> Languages -> Language URL Format and selected the "Language name added as a parameter" option -> Re-saved the permalinks and the issue persists.

Could you activate the debug mode by following the steps described in this link: https://codex.wordpress.org/Debugging_in_WordPress reproduce the issue and let me know if there is any error message in the debug.log file within wp-content folder?

Regards,
Carlos

August 30, 2019 at 11:18 am #4486825

markusS-65

Do I have this code:

// Enable WP_DEBUG mode
define ('WP_DEBUG', true);

// Enable Debug logging to the /wpcontent/debug.log file
define ('WP_DEBUG_LOG', true);

// Disable display of errors and warnings
define ('WP_DEBUG_DISPLAY', false);
@ini_set ('display_errors', 0);

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define ('SCRIPT_DEBUG', true);

in the wp-config.php install? If so, where?

What about the part? The should be installed according to the following instructions: / * That's all, stop editing! Happy blogging. * /

Unfortunately I have no experience with such changes.

August 30, 2019 at 11:28 am #4486841

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

The cause of the issue was that the slugs of the porfolio weren't translated. I translated the slug to French in WPML -> Settings -> Post Types Translation and the issue is solved 🙂

Regards,
Carlos

August 30, 2019 at 11:56 am #4486925

markusS-65

Great work! Thanks a lot for this. I still have a few questions. If I enter now in the Chrome browser moosmoos.fr this will automatically jump to the .de domain. Why ?

Thanks again!

August 30, 2019 at 12:01 pm #4486947

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

This might be caused by some outdated cache memory. If you visit moosmoos.fr in incognito you will see that the site in French is shown correctly.

Reegards,
Carlos

September 2, 2019 at 8:32 am #4495267

markusS-65

Now another problem has arisen. Each language should be tracked separately in Google Analytics. Can I just integrate the code specified by Google into the header?

September 2, 2019 at 11:08 am #4496451

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

As the original issue was solved I kindly ask you to open a new ticket describing the new one. This way we will be following our forum's rule of having one ticket per issue. It will also help future clients to find answers to similar questions when searching in the forum.

Thank you very much for your understanding!
Best regards,
Carlos

September 2, 2019 at 11:11 am #4496461

markusS-65

My issue is resolved now. Thank you!