We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 9 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
January 21, 2019 at 3:02 pm #3112968

indiaH

Tell us what you are trying to do? I managed to do my portfolio like this /fr/produits and then an item portfolio is /fr/produit/item-name same in english /en/products and then /en/product/item-name

Sometimes URLs are working fine but sometimes I got 404 errors... Sometimes there are too many redicrections. Is there a way to avoid that ?

January 21, 2019 at 3:21 pm #3113004

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

I regards to translate your custom post type slugs please follow this documentation:

https://wpml.org/documentation/getting-started-guide/translating-page-slugs/

I can also see you are using an outdated version of WPML. Could you please update WPML and its add-ons to the latest version
and let us know if the issue persists?
Before doing it, please create a reliable backup of your site.

Also please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please let me know if this solved your issue.

Kind regards
Andreas

January 22, 2019 at 1:43 pm #3116673

indiaH

Hello,

I updated everything and the issue is persisting. What can I do ?

Kind regards,
India

January 22, 2019 at 2:57 pm #3117082

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

January 28, 2019 at 8:31 pm #3137473

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

The issue on your site regarding random 404 errors might be related to a cache plugin. I can see you are using WPRocket. Could you please clear the cache and see if the issue persists.

I was trying to make a copy of your site with Duplicator for further tests. Sadly the package creation was not successful. We will need to determine which plugin causes the issue. Also I can see that you are having currently six updates available. Please make sure to keep any plugin updated.

Once the updates are completed please investigate again about if the 403 errors persists. If they do we will be able to migrate your site to one of our test servers for more debugging.

Let me know if you need further assistance.

Kind regards
Andreas

January 29, 2019 at 9:56 am #3139012

indiaH

Hello,

I've just updated everything and clear the cache but the issue is persisting.

Could you please check further ?

Kind regards,
India

January 29, 2019 at 10:18 pm #3141782

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I have made some research on our forum and I realized that lately there been quiet more issues similar to the one you are experiencing.

Those random 404 errors are most likely caused by a overwriting rule that causes changes in your htaccess file. Very possibly this issue is not related to WPML. Please have a look into the following errata in which you will find a workaround that hopefully will solve the issue.

https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

I was trying to access your server by FTP to check for server error reports but sadly the connection was not possible. A server error report might give you more information about why these 404 errors are occurring.

In some cases it was also resolved by changing the site URL structure to "Language name added as a parameter" instead of using the option "Different languages in directories". You can find this setting at WPML -> Languages -> Language URL format.

Please let me know if this solved your issue.

Kind regards
Andreas

February 4, 2019 at 1:01 pm #3157562

indiaH

Hello,

I put the temporary workaround code in my functions.php but it still the same.
How can I proceed with a server error report to let you know what's the cause of those issues ?

Kind regards,
India

February 4, 2019 at 1:58 pm #3157957

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

The error log can be obtained on your CPanel. Please have a look at the following article for more guidance.

hidden link

As mentioned in our errata this issue is very possibly not related to WPML. Could you please try to run your site for a time in minimal setup (WPML only) to see if the issue persists? Maybe would it be possible that you could setup a test site to investigate the issue?

Kind regards
Andreas

The topic ‘[Closed] portfolio URL slug seems to fail’ is closed to new replies.