This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Lauren 2 months ago.

Assigned support staff: Lauren.

Author Posts
January 24, 2020 at 5:23 pm #5358665

simoneM-27

The post category is missing from the slug in the post translation.

January 24, 2020 at 5:41 pm #5358719

simoneM-27

Hi, how can I go further and give credentials etc?

January 24, 2020 at 6:30 pm #5358889

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

January 28, 2020 at 1:46 pm #5377487

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for sending me the files. I set up a copy of your site locally and after these steps, the URL displays correctly:

1.Deactivate all non WPML plugins.
2. Resave permalinks
3. Go to WPML -> String Translation. Search for the term "reading" (use exact term and you should be able to find the category slug). Enter the translation for the string and save it.
After these steps, the URL was showing the correct translation in both languages.

I then reactivated all plugins one at a time and found that when Rank Math SEO was activated, the issue returned. Could you please test this on your live site by deactivating just that plugin, resave permalinks, and see if that resolves the issue?