This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 19, 2018 at 6:20 pm #2749753

jesper-boL

When I going to translate page is working fine but when I am going to translate post is not working fine. editor content is not showing.

Also when I have put the domain in the plugin, it's showing 404 error.

Please add:

Bluedock.com for English
and Bluedock.de for German

And then check. it's showing 404 error.

September 20, 2018 at 7:53 pm #2753205

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Below the custom fields it looks like there is page builder content. Is your post content displaying there? What type of content have you added to the post body?

I tried logging in to check but the link returns an error page. If you would like me to take a look, please share credentials in the next reply which I have marked as private.

September 20, 2018 at 8:28 pm #2753257

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see attached screenshot. This is what I see when I try to access the login page.

September 20, 2018 at 9:43 pm #2753355

jesper-boL

Please send you IP address

September 21, 2018 at 7:10 am #2754102

jesper-boL

[21-Sep-2018 07:00:52 UTC] PHP Catchable fatal error: Argument 1 passed to WPML_Slash_Management::parse_missing_host_from_path() must be of the type array, boolean given, called in /var/www/clients/i13921/concore.dk/web/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php on line 101 and defined in /var/www/clients/i13921/concore.dk/web/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-slash-management.php on line 85

September 21, 2018 at 12:30 pm #2755175

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

My IP address is 174.107.94.241

Please let me know when I can access the admin part of your site so that I can further troubleshoot. Thanks!

September 21, 2018 at 12:38 pm #2755195

jesper-boL

Check now please.

September 21, 2018 at 2:46 pm #2755610

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I was able to access your site now and see the issue. I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

September 21, 2018 at 5:21 pm #2756120

jesper-boL

I have done everything but not working.

September 21, 2018 at 5:59 pm #2756290

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. I created a new post to test this and when I translate the test post, the body content displays in the translation editor.

Please try this. Make a full backup of your site. Then, go to WPML -> Packages and delete the package for one of the post IDs where the body content is not displaying. Then, update the original post. Now when you translate the post, does the body content display in the editor?

September 21, 2018 at 6:07 pm #2756291

jesper-boL

I have a backup, Can you please do it for me.

September 21, 2018 at 7:15 pm #2756363

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to resolve the issue by deactivating all non WPML plugins and switching to theme TwentySeventeen. I then deleted the page builder package from WPML -> Packages (the package ID will match the page ID).

Next, I went to WPML -> Support -> Troubleshooting and clicked the following:

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

After this, when I went to translate the post, the body content appeared. Please see attached screenshot. I then reactivated all plugins and switched to your theme and the body field still displayed.

Please test this and let me know if the body field shows for you as well after these steps.

September 21, 2018 at 7:27 pm #2756379

jesper-boL

No, i can still not edit the content itself in post editor backend

September 21, 2018 at 7:32 pm #2756399

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I just completed the English translation in the translation editor. Which post are you looking at? Please send me a screenshot of what you are seeing.

September 21, 2018 at 7:47 pm #2756420

jesper-boL

Check this post.

hidden link