This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by claudiof-5 4 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 27, 2019 at 7:21 pm #3900495

claudiof-5

I am trying to: discover why these two posts are appearing for other countries when they should only be appearing for Brasil.

Link to a page where the issue can be seen:

These 2 posts are appearing in different languages, but we didn't create these translations:
hidden link
hidden link

They are appearing for other countries such as:
hidden link
hidden link
hidden link

I expected to see:
I expect to be able to see them only for the country selected when the posts were created: Brazil.

Instead, I got:
Instead, I can see them on the homepage of all countries.

May 28, 2019 at 4:13 am #3902657

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This is happening because apparently, you are using the "Translatable - use translation if available or fallback to default language" feature. Please follow the steps below:

- Click on the WPML > Settings > Post Types Translation
- On the "Posts (post)", make sure that the "Translatable - only show translated items" option is selected.
- Click on the Save button

This will makes only the posts actually translated to appear.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

May 28, 2019 at 1:34 pm #3907523

claudiof-5

My issue is resolved now. Thank you for helping me with this.