We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 21 replies, has 2 voices.

Last updated by christopheG-16 1 year, 1 month ago.

Assigned support staff: Bruno.

Author Posts
September 30, 2018 at 10:25 am

christopheG-16

I am trying to:
create a post (without tranlating in the beginning)
Link to a page where the issue can be seen:
hidden link
I expected to see:
A post created
Instead, I got:
Two posts created. I can't delete it (only one post, the name is the same for each). If I modify, I have free posts ! No problem without WPML !
Two languages defined, french and russian. I use Divi but the problem is the same without Divi Builder.

October 1, 2018 at 9:36 am #2777589

christopheG-16

I have a very big problem with WPML. I created a new post this morning and I have two posts :
hidden link
I can't detele only one of them because they are the same ! When I can delete (because it's not possible all time), all off them (with the same name) are deleted !

October 1, 2018 at 9:40 am #2777594

christopheG-16

screenshot

October 1, 2018 at 9:16 pm #2779534

christopheG-16

is there somebody home ?

October 2, 2018 at 3:39 am #2780288

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

When I try to access your site, this message is displayed: ERREUR : Nom d’utilisateur non valide. Mot de passe oublié ?

Please, could you check the credentials? Your next answer will be private.

Thank you.

October 2, 2018 at 8:41 am
October 3, 2018 at 7:57 am #2783833

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I need access only to test and verify why two posts are being created at once, rather than just one.

Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

October 3, 2018 at 8:06 am #2783846

christopheG-16

Yes you can. Thanks for your help

October 3, 2018 at 11:04 pm #2785896

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. The problem is happening because of the "Disable Comments RB" plugin. Disabling this plugin the problem seems to be solved.

Please, could you test? Just disable this plugin and try again to create a post and see if the problem persists.

Thank you.

October 3, 2018 at 11:23 pm #2785898

christopheG-16

1) I create a new post : I have always two new posts with the same title. 2) I disabling plugin "Disable Comments RB" 3) I create a new post : I have always 2 posts with the same title !
Nothing changed, I'm sorry.

October 5, 2018 at 8:07 pm #2791613

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Sorry for the delay. Please, could you check if your site is working properly now?

I deactivated all the plugins and activated again. After that, I can create posts without this being duplicated.

I noticed though that it looks like the WPML installation was not done correctly. Since you do not have any translated pages, the best option would be to reset WPML and install it again. Please follow the steps below:

- Please note that it is recommended to backup your site before following the steps below
- Click on the WPML > Support > Troubleshooting
- Scroll down and look to the "Reset" section, at the bottom of the page
- Check the "I am about to reset all translation and language data." option
- Click on the "Reset and deactivate WPML" button
- Click on the Plugins > Installed Plugins
- Enable the WPML and set it up again

This should fix the problem of removing the elements as well. Please, could you test?

Thank you.

October 6, 2018 at 2:23 pm #2792889

christopheG-16

I reseted like you said. After configuration I have this message (sorry for messages in french but WPML refuse I configure english for the langage of the site, in general parameters) : "WPML doit définir des langues pour les médias existants sur votre site." What can I define more ? The two langages I need for the web site (french and russian) are defined ! I can't test more if this problem isn't resolved. It can be the reason of these dysfunctions.

October 6, 2018 at 2:35 pm #2792894

christopheG-16

I don't know what you done on my site but now I have 3 pages "контакт". I need only one and it must be the russian version of the page "contact". If I delete one, probably all the 3 will be deleted. And the page "Акей" must be the russian version of "Accueil". How can I do ? On the top of the screen if I select Russian, there is zero page.

October 6, 2018 at 10:31 pm #2793149

christopheG-16

I don't understand if I can change the tittle of the page when I translate it on russian. WPML seems to never memorize which page is the tranlation of which other. Is-it necessary to select "duplication" ? It is not intuitive. I have tryed different possibilities. That's why I need your help. I wait. Thanks.

October 8, 2018 at 8:21 pm #2797247

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

On the first message, this is just for you to add the default language for some media file if any. It is only necessary to click the "Set languages" button and then "Start". After I've followed these steps, the message is no longer being displayed.

>>> I don't know what you done on my site but now I have 3 pages "контакт". I need only one and it must be the russian version of the page "contact". If I delete one, probably all the 3 will be deleted. And the page "Акей" must be the russian version of "Accueil". How can I do ? On the top of the screen if I select Russian, there is zero page.

I did nothing. So far I had not accessed your site again. I removed the two previous pages and kept only one page and it worked correctly.

When you are creating a new page in Russian, other than a translation of the page in French, make sure that the Russian language is actually selected. You can confirm this by looking at the language selector in the top bar. I fixed this just selecting the page language as Russian.

>>> I don't understand if I can change the tittle of the page when I translate it on russian. WPML seems to never memorize which page is the tranlation of which other. Is-it necessary to select "duplication" ? It is not intuitive. I have tryed different possibilities. That's why I need your help. I wait. Thanks.

For the translation to be done you can either duplicate the page (and then translate it independently) or you can click on the "+" button. Following these steps, you can not translate the page?

If you are translating the pages, please let me know the step by step you are following so I try to replicate this problem.