Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 21 replies, has 2 voices.

Last updated by christopheG-16 1 year, 1 month ago.

Assigned support staff: Bruno.

Author Posts
October 8, 2018 at 9:06 pm #2797328

christopheG-16

Ok thank-you for these modifications. I understand. But when I look at Accueil in french on front-end and when I selected russian, I have a 404 error and not the page "Акей". Why ? How can I say theses pages matches. I created "Акей" when I was on back-end on the page Accueil in french. I thought it was enough and it isn't.

October 10, 2018 at 9:42 pm #2805893

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

My sincere apologies for the delay. As you created the page in French but was not connected to the homepage in Russian, the home page in Russian returned error 404.

I just connected the homepage in Russian and the homepage in French. The page is now connected and does not return error 404.

Note that Russian content is not yet translated. The Homepage content in Russian is still French. You must translate this content manually. I'll attach an image for you to see.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 10, 2018 at 9:55 pm #2805909

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Just for explanation, the pages are connected when you click on the "+" icon to translate the content. You can look a little more detail in our documentation: https://wpml.org/documentation/getting-started-guide/

By clicking on the "+" button, you will add content the secondary language with the translated content.

Thank you.

October 10, 2018 at 11:04 pm #2805958

christopheG-16

I know my russian page is not really in russian, only some words in the middle. So you have connected Accueil to "Акей" but how ? I try to do it with "Contact" but I can't : finally I did it with deleting "Контакт" and recreated it on clicking on the sign "+".
I created another russian page with clicking on "copy" to have the french version to beginning. WPML copyed nothing so I had to click on the second button (overwrite the french content) and she system says the page will never be updated. It's probably the same option when the chek box "Duplicate" is near the sign "+". I used it before contact WPML support. There is no explication in "getting-started-guide" about this check-box (however, there is a screenshot). I don't understand at all the difference. I think it's the reason of my confusion since the begenning.

October 10, 2018 at 11:14 pm #2805961

christopheG-16

screenshot (see you tomorrow, it's one o'clock in the morning in Paris)

October 11, 2018 at 12:13 am #2806030

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The difference between the "+" button and the duplicate page is that to translate the content you must click on the "+" button. The duplicate option will synchronize the original content with the translated content.

As you're trying (from what I've seen) copy all Divi theme templates, then you should duplicate the page and then click on the "Translate Independently" button.

You can see more information at this link: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Here is another documentation (in this documentation we are using Visual Composer, but the steps are the same for the Divi theme - skip step 1 as long as you are not using Translation Management add-on): https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

October 12, 2018 at 3:38 pm #2812472

christopheG-16

Thank you very much. I think I understood. So I tested again creating posts, and after deleting all olds posts, creation was correct: no double any more! I don't really undestand why I have had all this problems before but now, it's ok. I close the case. My issue is resolved. Thanks for your patience.

October 12, 2018 at 3:39 pm #2812474

christopheG-16

My issue is resolved now. Thank you!