This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Sergio 1 year, 1 month ago.

Assigned support staff: Bruno.

Author Posts
April 10, 2019 at 2:14 pm

Sergio

I just translated a post from Polish to English.
hidden link
However the thumbnail is not loading. I also tried to cancel the image, and re-select it. But also this time loads forever.
I tried many times.

Can you please help?

April 10, 2019 at 4:15 pm #3578393

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I could not see the problem you are reporting. When I open the post you are showing above, I see that the image is already included in the post. I'll attach an image for you to see.

Should I take some other step to see the problem?

Thank you.

April 10, 2019 at 4:45 pm #3578869

Sergio

Hello, really strange.
I see thwe same loading symbol also on firefox, where I logged in for the first time ever. So to avoid cookies issues.

I also tried to log in on Firefox (I always use Chrome) with the temporary username I created for you, and also there I see the loading circle and not the thumbnail.

I have no idea what else I can check...

April 10, 2019 at 4:58 pm #3579025

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Have you tried to access your site using your browser's private window? Also, have you made any changes to any settings recently? If so, which one?

Thank you.

April 10, 2019 at 5:42 pm #3579721

Sergio

I logged-in with Incognito. See the picture attached....

April 10, 2019 at 5:53 pm #3579891

Sergio

To answer your question if I changed anything recently. No.
Apart from few updates to WPML in the last few months.

When it comes to "settings" I changed only "settings" in this post editing mode.
The old post was written in Polish and today/yesterday I decided to translate it into English.

Before clicking "translate" I saw this new switch "Use WPML's Translation Editor". It was set to OFF. I saw it for the first time and I turned it on.
Then the new wpml translator editor appeared. I wanted to come back to the old translating mode (normal post editing windows in the second language), but I was not able to make it back.

So I ended up in translating with the Translator Editor. I went to 100% translation progress, and saved. Then I went into the English post editing mode and I saw this problem with the loading icon.

After few tries, still the same. So I went into the settings and I saw that the options:
New content
Use WPML's Advanced Translation Editor
Use WPML's Classic Translation Editor

were both unselected. And:
Content that was created with WPML's Classic Translation Editor
Switch to using the Advanced Translation Editor (old translations may be unusable)
Use WPML's Classic Translation Editor

Was selected "se WPML's Classic Translation Editor".

So I selected on New Content -> Use WPML's Classic Translation Editor

Now this option is selected in the settings.
But the problem was happening even before I selected this option. I selected this because I was trying to find a way to make the image appear.

April 10, 2019 at 7:15 pm #3580709

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

For me, it seems like the problem is happening because of the format of the URL you are using, "A different domain per language".

Maybe by the time I accessed your site, this format was not set this way. I noticed that this is the error message that is happening: Access to fetch at 'hidden link' from origin 'hidden link' has been blocked by CORS policy: Request header field x-wp-nonce is not allowed by Access-Control-Allow-Headers in preflight response.

Since I do not have FTP access, please inside the wp-config.php file, add this line after the "<?php".

header('Access-Control-Allow-Origin: *');

After following these steps, please could you clear your browser's cache and try again?

April 10, 2019 at 7:25 pm #3580821

Sergio

Hello, the problem seems to be resolved.
Does every site with "different domain per language" has to have

header('Access-Control-Allow-Origin: *');

?

And do you have any idea why notepad++ is not marking the syntax in blue?
is it written correctly? See attached.

April 10, 2019 at 7:38 pm #3580953

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works.

>>> Does every site with "different domain per language" has to have

Yes. This is required so that the secondary domains can access the URL correctly.

>>> And do you have any idea why notepad++ is not marking the syntax in blue?

The "header" function may not have been highlighted by your code editor. Apparently, the code is right, though. If there is no error appearing on the site is because this function was inserted correctly.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

April 10, 2019 at 8:09 pm #3581165

Sergio

My issue is resolved now. Thank you!