This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Riffaz 4 months ago.

Assigned support staff: Riffaz.

Author Posts
February 18, 2019 at 7:37 am #3210371

doronN

I am trying to Translate a post, when clicking on "save and close" it is stock on saving and nothing happens. - tried changing the theme to default and disabling plugins - still stock.

February 18, 2019 at 9:13 am #3210649

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Please enable the WP Debug ode as explained here: https://wpml.org/documentation/support/debugging-wpml/
Save a post.
Let me know the error messages you are seeing.

Regards,
Riffaz.

February 20, 2019 at 10:02 am #3220681

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

A JS error may stop the rest of the JS execution, so this could be the reason.

It's webshocket related issue. so server related.
Could you please show this error to your hosting company and check with them?
If you still unable to save the posts after fixing this issue, let us know please.

Regards,

February 24, 2019 at 7:58 am #3236321

doronN

The JS error is from jetpack. Disabled jetpack and the issue is NOT resolved.
Also - disabled all plugins and set the default 2019 theme nd the issue is NOT resolved.
Any further advice?

February 24, 2019 at 2:39 pm #3236836

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

February 25, 2019 at 2:03 pm #3240198

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thanks for the login details.

I've recorded a video: hidden link
1. I created a test page
2. Translated to English

Translation editor works fine and when I click on "save & close" it works as expected.
Original page and the translation also work fine: hidden link
This is how it should work. Are you referring to something else or this has been fixed?

Anyhow, I see many JS errors in the console when work with posts and translations.
All are related to other plugins.
This may cause issue on your end.
Let me know how it goes.

Regards,

February 26, 2019 at 8:45 am #3243527

doronN

Try the arab translation of this post
hidden link

I don't see JS Error - it looks like the one you see are (maybe) for extensions you run

February 26, 2019 at 9:59 am #3244001

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Yes, in that page Arabic translation just freezes like this hidden link

So this happens only on this page, right?
I suggest you to copy the content of this page and paste it into new page and then try to translate.
If not, just enable the WP Debug mode as explained here https://wpml.org/documentation/support/debugging-wpml/ and try save that post again.
And give me the new errors you see on the screen or the debug.log file.

Regards,

February 28, 2019 at 1:57 pm #3255600

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I checked this with the team.

All suspect this because of your max input vars.
Please increase your MaxInputVars to 10000 and the WP Memory limit (https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP) to as much as you can and then check the issue.

MaxInputVars:
You can use php.ini or .htaccess if your host allows.

=> php.ini file

Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link

=> .htaccess file

php_value max_input_vars 10000

Sometimes if you are in a shared hosting you have to contact your hosting support for this.

Let me know how it goes.

Regards,

March 4, 2019 at 12:04 pm #3268467

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay.
We had to inspect a lot regarding this.

Admin ajax fails on that page when we try to save the translation: hidden link

1. Could you please delete all the errors you have in your error.log?
2. And, enable the WP Debug mode: https://wpml.org/documentation/support/debugging-wpml/
3. go to the translation editor in the page that hangs
4. open developer tools and go to network tab
5. click 'save and close'
6. a new entry should show in the network tab, check the response
7. click on the admin-ajax.php

Now check your debug.log and there should be some errors on the file.
Send us it.

This is very that we don't have any error message in the debug log even after this.
In that case we need to replicate your site and need to check it in our hosting locally.

Let me know.

March 8, 2019 at 10:19 am #3291148

doronN

This is what appears on the log after I cleared it
[08-Mar-2019 10:14:18 UTC] PHP Notice: Trying to get property of non-object in /home/dialogto/domains/dialogtogether.com/public_html/wp-content/themes/armonioso-child/functions.php on line 127
[08-Mar-2019 10:14:18 UTC] PHP Notice: Trying to get property of non-object in /home/dialogto/domains/dialogtogether.com/public_html/wp-content/themes/armonioso-child/functions.php on line 128

After I click save, the admin-ajax.php in developer tools ->network->XHR
{"success":false,"data":0}

The saving Icon is stock and wp-admin keeps producing wp-auth-check ever couple of minutes

{"wp-auth-check":true,"server_time":1552039988}
{"wp-auth-check":true,"server_time":1552040048}
{"wp-auth-check":true,"server_time":1552040168}
{"wp-auth-check":true,"server_time":1552040288}

I can create a testing environment on my server - for you to fiddle with as much as you want. Let me know if that will work and how to send the details

Doron

March 11, 2019 at 10:16 am #3309653

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I've sent this to our team to check this internally.

Please be patient till we get back to you.

Regards,

March 21, 2019 at 11:38 am #3400081

doronN

Hey
Migration completed
hidden link

Thanks!

March 24, 2019 at 6:07 am #3447767

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay.
I do not work on Fridays and saturdays.

Did you check the migrated site?
It goes 403 : hidden link
I will check this again with the corresponded department and will get back to you on Monday evening.

Regards,

March 24, 2019 at 8:24 am #3447871

doronN

When I visited it was OK (after the migration) check with hosting support.