Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Instead of seeing the translated posts, I see "nothing found here" on the category elements.

Solution: Go to WPML > Support > Troubleshooting -and click on the button "Synchronize posts Taxonomies" make sure "Posts" are selected in the drop down menu.

Relevant Documentation: https://wpml.org/forums/topic/synchronize-post-categories-to-translated-posts/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by davidF-76 1 year, 2 months ago.

Assigned support staff: Marcel.

Author Posts
May 26, 2019 at 7:06 pm #3892327

davidF-76

See the reader responses here:
hidden link
They are all translated.

Instead of seeing the translated posts, I see "nothing found here" in the Arabic version:
hidden link

All of my categories are translated in the taxonomy editor, I believe.

May 27, 2019 at 8:56 am #3894927

Marcel
Supporter

Languages: German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

It looks like Arabic is not a visible language, or there is no content translated to Arabic. Could you please send me a specific example, as the URL with ?lang=ar redirected to English.

Please let me know.

Best Marcel

May 28, 2019 at 5:29 am #3902797

davidF-76

Hi Marcel, I have made Arabic visible now to anyone.
You can see the Arabic HP here:
hidden link

The english HP here:
hidden link

My concern is specifically around the widget next to the "See all reader responses" link

May 28, 2019 at 7:13 am #3903247

Marcel
Supporter

Languages: German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi David,

thank you. I can follow the issue now.

I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen

Best Marcel

May 29, 2019 at 8:24 am #3913017

Marcel
Supporter

Languages: German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi David,

could you please provide me with full admin access? Otherwise, I don't have the right to open the translation to check if it's loading the correct category ID of the blog posts.

Thank You

Best Marcel

May 29, 2019 at 7:24 pm #3918325

davidF-76

Done.

May 30, 2019 at 4:36 pm #3924989

Marcel
Supporter

Languages: German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

the problem is indeed that the posts are loaded with the wrong category id:

Example:
English "Reader Responses" = ID 92
in Arabic = ID 99

It looks like there is no option in the Theme to make the "Isotope" Post element translatable, even not If I activate the radio buttons for it on the bottom of the page. I will try to make it translatable via a custom XML config. It could be that this element is added new to the Uncode Theme, this I need to find out.

Please give me some time to try this out.

Best Marcel

May 30, 2019 at 5:13 pm #3925285

davidF-76

Thank you, Marcel. Is there a workaround we can pursue in the meantime or do we expect that a fix can be reached in <24hours? Thank you again.

June 2, 2019 at 5:31 pm #3937777

davidF-76

Hi, I resolved this issue by following the steps here:
https://wpml.org/forums/topic/synchronize-post-categories-to-translated-posts/