This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.51 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by arminS-15 6 months, 2 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
February 1, 2019 at 1:09 pm #3151662

arminS-15

Hello WPML Team,

I am trying to:
Show translated posts in a post list for our news page.
We use elementor as a page builder and 'Elementor Addons & Widgets' plugin along with other plugins. The origin language is german which is translated to english.

When we translate the posts, the post content is not shown in the list of the english version.

Link to a page where the issue can be seen:
I've created a dummy page showing this problem (sorry, the layout styling isnt good at this page):

hidden link

I expected to see:

-First post is created in german and afterwards translated to english:
german works, english: post content not showing
- second post is created in english than translated to german:
both, german and english not working. Here i also added post excert, whic does work in both
- the test post, just ignore it..

Three tests made with this elementor elements:
1. EAW Post Grid
2. Standard elementor post element
3. EA Post Grid (Essential Addons for elementor plugin)

Errors encountered in backend:
- Sometimes server error 500 while saving elementor changes (in frontend editing) but things are saved
- On translating posts, some fields doesent appear in the translator for editing
- when reopening the translations editor some fields are unchecked again
- while saving in translations editor nothing happens. For example clicking on 'Save & Close' button, the animation 'Saving...' starts but no action of the page

Thank you for your help!

Instead, I got:

February 2, 2019 at 3:02 pm #3154347

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

1. From your description, these seem like known issues that are already been solved in the latest versions of Elementor and WPML plugins.

Can you please update your site to the latest versions of Elementor, WPML and its active add-ons?
You can check the latest released versions under “My Account -> Downloads” on this site.
- https://wpml.org/account/downloads/
Instructions to update can be found here:
- https://wpml.org/faq/install-wpml/#automated-updates

❌ Before proceeding please make a full website backup! ❌

2. The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '128M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

You can check the current WP Memory Limit value from WPML -> Support in the Info section

More info here:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
- https://wpml.org/home/minimum-requirements/

Please let me know if this solves the issue or if you need further details.

Thank you

February 8, 2019 at 3:42 pm #3175999

arminS-15

Hello Vincenzo,

thank you for your support so far..
While updating all relevant plugins, i encountered a problem with updating the WPML Plugins.

Update of the WPML Multilingual CMS got an error at first, than somehow after second attempt, it was updated to v4.2.0

WPML Media error:
Update Failed: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
Also state changed to deactivated and not able to activate again

WPML String Translation error:
Update Failed: Download failed. Not Found

WPML Translation Management error:
Update Failed: Download failed. Not Found

The WP memory limit is set to 128M successfully

How can I proceed? What if i download the current versions of those three plugins and install it via upload funktion? Would it override some settings?

Do you need to login to the page, icould provide you the credentials.

Best regards and thanks!

February 8, 2019 at 3:52 pm #3176058

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

this is a known issue. Our Systems team is working on it.

In the meantime, try these steps:
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button
- Try to update the plugins

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not fix the issue you can manually update the plugins.
❌ Before proceeding please make a full website backup! ❌
- Download the latest version of the plugins that need to be updated from https://wpml.org/account/downloads/
- Disable the outdated ones
- Delete them (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded plugins from Plugins -> Add New -> Upload Plugin
- Activate them

Please let me know if this solves the issue or if you need further details.

Thank you

February 11, 2019 at 1:52 pm #3183158

arminS-15

My issue is resolved now. Thank you!

This steps finally were able to update the plugins:

In the meantime, try these steps:
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button
- Try to update the plugins

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

=> now try to update the plugins again, this worked for me!

Thanks for the good support!
Best regards, Daniel Scheibe